We run Magento 2.4 with php7.4, that should be supported. But we get the following error when we try to update a module using composer:

magento/magento2-functional-testing-framework 2.6.5 requires php ~7.1.0||~7.2.0||~7.3.0 -> your PHP version (7.4.7) does not satisfy that requirement.

Installation request for magento/magento2-functional-testing-framework (locked at 2.6.5, required as ~2.6.4) -> satisfiable by magento/magento2-functional-testing-framework[2.6.5]

How can we solve this?

3 Answers 3


Update to "~3.1.0". You can get list of available versions like this

composer show magento/magento2-functional-testing-framework 3.*.* --all | grep -m 1 versions
  • Thanks, but when we run the composer update command, there is not update available. And why is this module not updated by Magneto when we update to 2.4?
    – JGeer
    Sep 21, 2020 at 19:56
  • In composer.json set it like this "magento/magento2-functional-testing-framework": "~3.1.0" , And run composer update. Sep 22, 2020 at 7:42
  • Thanks, but than we get: magento/magento2-functional-testing-framework 3.1.0 requires symfony/finder ^5.0 -> satisfiable by symfony/finder[v5.0.0, v5.0.1, v5.0.10, v5.0.11, v5.0.2, v5.0.3, v5.0.4, v5.0.5, v5.0.6, v5.0.7, v5.0.8, v5.0.9, v5.1.0, v5.1.1, v5.1.2, v5.1.3, v5.1.4, v5.1.5]. - Conclusion: don't install symfony/finder v5.0.1
    – JGeer
    Sep 22, 2020 at 12:35
  • its not work for me
    – matinict
    Jun 16, 2022 at 4:16

if you look at magento 2.4 open source composer files, you will find


so try 3.0 version


there are few changes that you need to do in your composer.json Me helped: https://github.com/magento/magento2/issues/29350#issuecomment-751921479

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.