5

I have a Magento instance and I have enabled Scheduled Backup in System > Configuration > Advanced > System > Scheduled Backup Settings. These are the settings I have:

 Enable Scheduled Backup: Yes
 Backup Type: Database
 Start Time: 1:00 am
 Frequency: Daily
 Maintenance Mode: No

The problem is that this setup doesn't do anything at all. Do I have to do something else on the backend? Do I have to setup a cron job on the system? Where can I check a log or something like that?

Thanks for your help

3

To make sure cronjobs are executed, start off by installing the excellent AOE Scheduler: http://www.magentocommerce.com/magento-connect/aoe-scheduler.html

After installing this you'll know whether cronjobs are running, which ones are and at what time.

If they aren't working please write in details what you have done so far to get cronjobs running. (what hosting are you on and what cronjob settings did you use).

Or:

An easier way to check if cronjobs are working is to edit /cron.php and add:

Mage::log('cron executed at: ' . date("H:i:s"));

This will add 'cron excecuted at: 20:43:30' to the system.log file in /var/log/ every time the cronjob runs.

  • Thanks for the answer. I installed the AOE Scheduler but now I am getting this notice on top of the admin screens: No heartbeat task found. Check if cron is configured correctly. I can't find anything on the module documentation. Do you know what else do I have to do to make it work? – jpruizs Aug 15 '14 at 1:46
  • So it means you haven't set up cronjobs:) look here for instructions: magentocommerce.com/wiki/1_-_installation_and_configuration/… – willem wigman Aug 15 '14 at 7:24
  • hi @BabyinMagento2, it would be best to create a new question instead of hooking into this one. That being said, you get into the cronjobs (after logging into the server via ssh) by typing 'crontab -e' there you can paste the code you referred to. Here's a quick introduction cloudaccess.net/additional-resources/58-ftp-sftp-ssh/… – willem wigman May 18 '15 at 15:50
2

It may be time out issue for large size of backup.please check max execution time in Php settings

  • Would that also affect manually run backups? For instance, if the backup run manually works fine can we expect the automatic backup to succeed too? – Brian Knoblauch Oct 9 '14 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.