5

I have a situation where two admin users can go into a Product Information page and see the product images in the Images tab - when rolling over the image - but two other users can't see them.

For the users who see them the record in the Images table is visible. For the other two users, it looks like the image record is not there.

Here are screenshots for the same product for the two different users.

No Images:

No images

Images:

Images

They all have the message "Image type and information need to be specified for each store view" on screen. Whether or not that is an issue I don't know.

The only other difference for the two user types is that the ones that can't see the images have a reduced permissions role - taking out the dashboard, reports & config. However I have bumped them up to full admin rights and flushed the cache and still, they can't see the images.

Does anyone have any idea?

  • 2
    it may be flash player issue in browswer – Amit Bera Aug 14 '14 at 4:31
  • @AmitBera - Flash? Is that being used in Magento Admin? – Enigmativity Aug 14 '14 at 6:29
  • 1
    @Enigmativity yes, Flash is used for the image upload functionality. Have the users who can't see the images tried on other computers? Are there ad-blockers or other browser plugins installed? – Jonathan Day Sep 13 '14 at 23:49
  • 1
    I don't think it has anything to do with the flash parts of that page, since this is unrelated to the upload portion. However, that image grid is constructed using javascript. My guess would be that the people not seeing the images are having javascript issues, either because they are blocked or browser plugins that are msesing it up. Are you seeing javascript errors? – Rian Nov 8 '14 at 16:25
  • @damian - You need to not include the space when @ notifying someone - so @JonathanDay works, but @Jonathan Day doesn't. – Enigmativity Jan 17 '16 at 23:50
2

As stated in the comments, this may be a Flash issue. The image display functionality in the admin is theoretically not really related to Flash, but the missing Flash plugin causes errors which prevent the display of the images. If you are on newer Ubuntu versions (like 14.04 as the time of writing), make sure you have the packages flashplugin-installer as well as pepperflashplugin-nonfree installed with the following command:

sudo apt-get install flashplugin-installer pepperflashplugin-nonfree

Afterwards, restart your browser and try again.

| improve this answer | |
2

I was facing the same problem and logged in with a browser that has flash installed an now it all works as expected. At least for me flash fixed it. Thanks Amit Bera and others who suggested it. I would have never thought of that.

| improve this answer | |
  • The image uploader uses Flash, typically the inability to see or upload images in Product Maintenance happens when you are using FireFox and the Flash Player plugin has not been installed on your system. Both Chrome and Internet Explorer come with Flash support preloaded so they can auto-update as Flash continues to expose horrendous flaws that allow system compromise. – Fiasco Labs Jan 17 '16 at 19:42
2
  1. I had this situation when I installed Adblock Plus add-on for Firefox. It blocked Flash Player right after installing it.

  2. Since Flash Player was blocked I got a message:

"Image type and information need to be specified for each store view"

...and Browse/Upload Images (buttons and functionality in general) became unavailable.

  1. And yes - Flash Player is used in Magento's image uploading section.
| improve this answer | |
2

I know it's been a long time since this question was asked but got the same situation and tried what I know from Magento backend, (clearing cache, indexing, removing cache file from FTP server, etc) did nothing. So as someone suggested, tried installing Flash, and actually didn't work, but when I looked at the security details right next to the URL section on Chrome and changed Flash setting to "Always Allow" then it did the trick, uploader showed up again. It is a very easy solution but if someone still needs it, I think worth a try.

enter image description here

| improve this answer | |
1

Image type and information need to be specified for each store view:

  1. Go to File structure root/media/ dhl
  2. Cut or delete the “dhl” folder from there.
  3. Clear cache from Admin Panel and now do upload the images
  4. Hope, Its working good.
| improve this answer | |
0

I guess that you shall view the file .htaccess form media or from root directory of magento if it has any rule that not permit some IP address ,or any secure http proxy that block flash content, I have some similar problem, and .htaccess has a password for any IP address, hope that this help you.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.