1

We have install magento 2.4 successfully with Rabbitmq Server 3.8.8. All seems to work fine in server side.

But in admin when we try to update product attributes with magento native process we have issue with queue messages which never go to success status

Scenario is:

  1. Select in admin catalog more than 1 products. No matter how many
  2. Go to >Actions > Update Attributes
  3. Change one or more attributes to change in the selected products
  4. Save

We get the message:

Message added to queue

And magento creates in the upper section the bar with messages

Magento message queue bar

The selected products attributes are changed successfully.

But magento message never go to success stage. It stays to pending, queue

We don't have any errors in magento logs. Crons are finished successfully without errors also. In rabbitmq server also we don't have any error. We have successful connection when mass edit magento process is starting

Anybody has seen this please? Any suggestion where to look to fix it?

1
Please following command on CLI

php bin/magento queue:consumers:start exportProcessor

For more information https://devdocs.magento.com/guides/v2.4/config-guide/cli/config-cli-subcommands-queue.html

  • Hi. I tried your command. It seems that is running in console but in admin messages are still in pending queue and attributes are updated just fine. It is now working – G. G. Sep 16 '20 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.