0

I am afraid of upgrading my magento version because my store is all setup. My php version is 7.3.20 and I thinking of upgrading to

magento version 2.4.0


composer require magento/product-community-edition=2.4.0 --no-update

Will it cause conflicts?

2
  • 1
    composer require magento/product-community-edition=2.4.0 --no-update should work no issues and should not cause any conflicts. the only conflicts you may see is with 3rd party modules. once you have upgraded your magento version run composer update which should update all 3rd party modules in the vendor directory if you have modules in app/code you will need to upgrade these manually Sep 14, 2020 at 19:54
  • 1
    @Anonymous Record, first takes backup and try it. Sep 15, 2020 at 11:18

1 Answer 1

0

First take the backup of your magento and database

In composer.json file update "magento/product-community-edition": "2.3.2" to "magento/product-community-edition": "2.4.0"

Now run the below command:-

  1. bin/php -d memory_limit=-1 vendor/composer/composer/bin/composer update
  2. php bin/magento setup:upgrade
  3. php bin/magento setup:static-content:deploy -f
  4. php bin/magento setup:di:compile
  5. php bin/magento indexer:reindex
  6. php bin/magento cache:clean

check your Magento version with the Below command php bin/magento --version

It will update your magento version and all the modules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.