1

I am using Magento ver. 2.3.5-p1 and I have trouble changing the "Wellcome message", the logo, and the copyright. I have managed to change them once by going on the admin page, then Content->Design->Configuration->Edit. In Header, if I try to change the logo image or the size or the Welcome message, the changes will not appear on the store website. I also try to change the copyright in Footer with the same result. Things I've tried:

  • Save Configuration -> Flush Magento cache - in Admin panel
  • Save Configuration -> Flush cache storage -> Flush Catalog Images cache -> Flush JavaScript/CSS cache -> Flush Static Files cache - in Admin panel
  • magento setup:upgrade -> magento setup:di:compile - in terminal

The messages (Wellcome message and the copyright) and the logo are not changing. Why?

  • Try accessing website with query string or another browser – Hamendra Sunthwal Sep 8 at 6:34
  • I've tried that... no change :( – Mihai Popescu Sep 8 at 8:24
  • Are you sure it has been stored as store wise ? Just take a quick look at the settings where it has been saved – Hamendra Sunthwal Sep 8 at 9:21
  • In Design Configuration there is only one record (not 3 as normal): Default - Global; Website - Main Website; Theme Name - Magento Luma. There is where I've made the changes. – Mihai Popescu Sep 8 at 9:34
  • Are you selecting the right view? global – Dava Gordon Sep 8 at 17:57
0

In the end, I've managed to make the changes by updating the database. I've looked for design/header/welcome and change the value to the message I want. Did the same for design/footer/copyright and for design/header/logo_src.

After that, in terminal:

./magento setup:upgrade

./magento setup:di:compile

Perhaps is not the best way but works for now.

| improve this answer | |
  • this is not the right approach these things can be easily changed from the magento backend and if you changes are not visible then this could be the cache issue try to check the changes in private windows – Pramod Sep 9 at 5:58
  • You must understand, I've tried everything else without result. – Mihai Popescu Sep 10 at 3:42
0

I have a better answer: I selected Stores-Settings-Configuration-General-General then in the bottom of the page there is a setting called "Enable Single-Store Mode". After changing that to "No" I could make my changes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.