0

I am installing a fresh Magento 2.4 on a docker-compose stack with these specs:

  1. Reverse proxy: jwilder/nginx-proxy
 ports:
      - "80:80"
      - "443:443"
    volumes:
      - conf:/etc/nginx/conf.d
      - vhost:/etc/nginx/vhost.d
      - html:/usr/share/nginx/html
      - dhparam:/etc/nginx/dhparam
      - ./certs:/etc/nginx/certs:ro
      - /var/run/docker.sock:/tmp/docker.sock:ro
    networks:
      - nginx-proxy
  1. web running apache expose on port 80 and 22.

Long story short, I have had no problem installing magento 2.3.5 and before that with that docker-compose setup. But starting Magento 2.4.0, I added elasticsearch container to my setup, confirm seeing setup landing page "Welcome to Magento Admin". But after i run /bin/magento setup:install with Basic install. I am getting "502 Bad Gateway". I suspect my reverse proxy can't detect my web container apache after running setup:install but it was able to see it before running setup:install. So what change to my apache.conf file I need to setup to get thing work again. What could go wrong here. I can't think of any. Any help?

Thanks

  • 1
    did you have any luck with this? I have the same issue... – outeredge Nov 2 '20 at 18:29
  • Please see this magento.stackexchange.com/questions/319278/… I fixed it but can't remember exactly steps I took. Long story short, I still stick around with 2.3.6 because some of my modules are not compatible with 2.4.1 – Long Le Nov 3 '20 at 18:15
  • Thanks, I'll give that a go! – outeredge Nov 4 '20 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.