0

I have updated Magento version 2.3.5-p1 to Magento 2.4.0 but after upgrade products not showing in front side.

I have reset index also it's showing valid

enter image description here

I've tried the following things in an attempt to fix it, but none of them helped:

  • Re-indexing Checking Visibility is set to Catalog & Search for all products
  • Checking Status is set to Enabled for all products
  • Checking Inventory is greater than 0 and status is set to 'In Stock' for all products Checking Website is set to base for all products
  • Flushing all Caches
  • Switching to default Luma theme to see if it was a theme bug (didn't work)
  • Disable All 3rd Party plugin.
  • In Product collection, it's showing 0 counts but when I run collection query in DB then products come in result
  • Source assigned to the website
2
  • Do you see data in elasticsearch? you can try querying elasticsearch directly also to see if there is anything in there – Arif Ahmad Aug 28 '20 at 7:03
  • can you give me some example @arif – Pushpendra Singh Aug 28 '20 at 7:16
0

try to check product visibility , it should be catalog, search. if you are looking on product list page you should attach your products to the category. If you are lookig on serach check products on your search engine.

Another way try to check if your product pag is accessible by url /catalog/product/view/id/{product_id}

last thing check your product attribute set.

Hope that helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.