0

I have installed the Magento 2.3.5 successfully into my machine locally. After opening the admin page it show below error.

I am using PHP 7.3 version & installed Magento on Windows 10. Also when I try to open admin & homepage its take huge time to load. Please suggest on this.

Below is the log data:

{"0":"SQLSTATE[HY000] [1130] Host 'localhost' is not allowed to connect to this MariaDB server","1":"#1 Zend_Db_Adapter_Pdo_Mysql->_connect() called at [vendor\\magento\\framework\\DB\\Adapter\\Pdo\\Mysql.php:410]\n#2 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql->_connect() called at [vendor\\magento\\zendframework1\\library\\Zend\\Db\\Adapter\\Abstract.php:861]\n#3 Zend_Db_Adapter_Abstract->quote('store_website', NULL) called at [generated\\code\\Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor.php:1636]\n#4 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor->quote('store_website') called at [vendor\\magento\\framework\\DB\\Adapter\\Pdo\\Mysql.php:1181]\n#5 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql->showTableStatus('store_website', NULL) called at [generated\\code\\Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor.php:271]\n#6 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor->showTableStatus('store_website', NULL) called at [vendor\\magento\\framework\\DB\\Adapter\\Pdo\\Mysql.php:2618]\n#7 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql->isTableExists('store_website', NULL) called at [generated\\code\\Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor.php:700]\n#8 Magento\\Framework\\DB\\Adapter\\Pdo\\Mysql\\Interceptor->isTableExists('store_website') called at [vendor\\magento\\module-store\\App\\Config\\Source\\RuntimeConfigSource.php:92]\n#9 Magento\\Store\\App\\Config\\Source\\RuntimeConfigSource->getEntities('store_website', 'code') called at [vendor\\magento\\module-store\\App\\Config\\Source\\RuntimeConfigSource.php:58]\n#10 Magento\\Store\\App\\Config\\Source\\RuntimeConfigSource->get('') called at [vendor\\magento\\framework\\App\\Config\\ConfigSourceAggregated.php:40]\n#11 Magento\\Framework\\App\\Config\\ConfigSourceAggregated->get('') called at [generated\\code\\Magento\\Framework\\App\\Config\\ConfigSourceAggregated\\Proxy.php:95]\n#12 Magento\\Framework\\App\\Config\\ConfigSourceAggregated\\Proxy->get() called at [vendor\\magento\\module-store\\App\\Config\\Type\\Scopes.php:63]\n#13 Magento\\Store\\App\\Config\\Type\\Scopes->get('stores\/1') called at [vendor\\magento\\framework\\App\\Config.php:132]\n#14 Magento\\Framework\\App\\Config->get('scopes', 'stores\/1', array()) called at [vendor\\magento\\module-store\\Model\\StoreRepository.php:106]\n#15 Magento\\Store\\Model\\StoreRepository->getById(1) called at [vendor\\magento\\module-store\\Model\\StoreRepository.php:127]\n#16 Magento\\Store\\Model\\StoreRepository->getActiveStoreById(1) called at [vendor\\magento\\module-store\\Model\\StoreResolver.php:181]\n#17 Magento\\Store\\Model\\StoreResolver->getDefaultStoreById(1) called at [vendor\\magento\\module-store\\Model\\StoreResolver.php:126]\n#18 Magento\\Store\\Model\\StoreResolver->getCurrentStoreId() called at [vendor\\magento\\module-store\\Model\\StoreManager.php:160]\n#19 Magento\\Store\\Model\\StoreManager->getStore(NULL) called at [generated\\code\\Magento\\Store\\Model\\StoreManagerInterface\\Proxy.php:119]\n#20 Magento\\Store\\Model\\StoreManagerInterface\\Proxy->getStore(NULL) called at [vendor\\magento\\module-store\\Model\\Resolver\\Store.php:30]\n#21 Magento\\Store\\Model\\Resolver\\Store->getScope(NULL) called at [vendor\\magento\\framework\\App\\Config\\ScopeCodeResolver.php:49]\n#22 Magento\\Framework\\App\\Config\\ScopeCodeResolver->resolve('stores', NULL) called at [vendor\\magento\\framework\\App\\Config.php:69]\n#23 Magento\\Framework\\App\\Config->getValue('admin\/url\/use_cu...', 'stores') called at [vendor\\magento\\module-backend\\App\\Area\\FrontNameResolver.php:123]\n#24 Magento\\Backend\\App\\Area\\FrontNameResolver->isHostBackend() called at [vendor\\magento\\module-backend\\App\\Area\\FrontNameResolver.php:106]\n#25 Magento\\Backend\\App\\Area\\FrontNameResolver->getFrontName(true) called at [vendor\\magento\\framework\\App\\AreaList.php:76]\n#26 Magento\\Framework\\App\\AreaList->getCodeByFrontName('') called at [vendor\\magento\\framework\\App\\Http.php:111]\n#27 Magento\\Framework\\App\\Http->launch() called at [generated\\code\\Magento\\Framework\\App\\Http\\Interceptor.php:24]\n#28 Magento\\Framework\\App\\Http\\Interceptor->launch() called at [vendor\\magento\\framework\\App\\Bootstrap.php:261]\n#29 Magento\\Framework\\App\\Bootstrap->run(&Magento\\Framework\\App\\Http\\Interceptor#000000003f90d9b70000000079af4522#) called at [index.php:39]\n","url":"\/magento2\/","script_name":"\/magento2\/index.php","report_id":"6ba38d89b51e2f5a0b8a3b4274223bf7b2992af8ba79df76f9d117bbd7a7c71c"}

enter image description here

0

This error is solved. I was having an phpmyadmin access denied issue. I have fixed that & this issue resolved, but still homepage & admin page is working very slow.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.