0

im using a fresh magento install from Ionos 1&1 (CentOS 8), and just after doing composer require, I test if the module installed correctly, but it says it cant be found. Here is the output:

[root@localhost html]# composer require maurisource/lightspeed
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Warning from repo.magento.com: You haven't provided your Magento authentication keys. For instructions, visit https://devdocs.magento.com/guides/v2.3/install-gde/prereq/connect-auth.html
    Authentication required (repo.magento.com):
      Username: (hidden)
      Password:
Do you want to store credentials for repo.magento.com in /root/.composer/auth.json ? [Yn] y
Using version ^1.3 for maurisource/lightspeed
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing maurisource/lightspeed (1.3.2): Downloading (100%)
Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Package sebastian/finder-facade is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files
PHP CodeSniffer Config installed_paths set to ../../codeception,../../magento/magento-coding-standard,../../phpcompatibility/php-compatibility
[root@localhost html]# bin/magento module:status maurisource_lightspeed
Module does not exist

It is happening with different modules. Any ideas on what i can do? Thanks in advance

5
  • You will have to contact the module developer. Looks like maurisource/lightspeed is not available in composer. – Adarsh Khatri Aug 17 '20 at 1:15
  • It is, i am quite sure of it, as ive already used it on another magento website, months ago. You can see for exemple that it found version 1.3 all by itself. Also, this bug is happening with every module, even those i install without composer. – Jorge Perez Aug 17 '20 at 1:47
  • You should run bin/magento module:status to list uninstalled modules. Then bin/magento module:enable Vendor_Modulename to enable it and finally bin/magento setup:upgrade to register it. – Jonathan Ribas Aug 17 '20 at 3:27
  • module name in status command is case sensitive, use bin/magento module:status to list all modules and check or use bin/magento module:status | grep lightspeed – paj Aug 17 '20 at 7:24
  • Checked the module list as you suggested Jonathan, but the modules dont appear in the list. Which is normal since this seems to be an installation issue, and the error I posted before was "Module does not exist". – Jorge Perez Aug 17 '20 at 16:13
0

Wasnt able to solve this, however formatting the server, and manually installing magento and everything else, solved this bug. So im guessing it was just the ionos image which wasnt working well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.