3

When I edit something in system -> configuration, it doesn't matter where, for example i want to edit the store contact address, it doesnt save my edit.

I can change and add products but I cant edit anything in the configuration.

The System log and exception log are empty and no errors are shown. Is says "The configuration has been saved."

Does someone know how to fix this.

Magento version: 1.9.3.6

EDIT: I have noticed that this problem has occurred when we applied patch SUPEE 11219 When i revert that patch we can save config in the backend again. Any idea?

4
  • in this patch which system.xml files are updated? Aug 17, 2020 at 14:11
  • I dont see any edited system.xml our the git repo Aug 19, 2020 at 12:21
  • would you be able to open your browser console and if there is any red message to screenshot the message.. console and network tab can also be useful Aug 22, 2020 at 17:40
  • looks like all our answers are not pinpointing your issue accurately as the origin with the error can be varied, happy to take a look if you provide a public url and temporary admin password that may be restricted to config area (and you'll need to have a database backup). ideally, the envrionment would be dev Aug 23, 2020 at 11:10

3 Answers 3

2
+25

You need to check "max_input_vars" in your php configuration. Try to increase "max_input_vars" value and test.

ini_set('max_input_vars','5000' );

You need to set it with php.ini or .htaccess file.

1

navigate to

app/code/core/Mage/Core/etc/config.xml

Find

<log>
    <active>0</active>
    <file>system.log</file>
    <exception_file>exception.log</exception_file>
</log>

Replace

<log>
    <active>1</active>
    <file>system.log</file>
    <exception_file>exception.log</exception_file>
</log>

Note: this is not a solution this will help you in getting the error then once you know the error kindly update the question with the error details

3
  • I have changed the config of the file you mentioned. we sadly dont get anything in the logging. There is 1 error but i dont think its related to the backend issue. The error is: Array to string conversion in /data/web/public/lib/tcpdf/tcpdf.php on line 1849 Aug 13, 2020 at 12:15
  • did u flush the cache?
    – Pramod
    Aug 13, 2020 at 12:25
  • Yes i did flush the cache Aug 13, 2020 at 12:43
0

In your magento root folder, there is index.php file, In that file the code like this one

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
    Mage::setIsDeveloperMode(true);
}

#ini_set('display_errors', 1);

Form that code, remove the # from this line :

ini_set('display_errors', 1);

So your code look like this one:

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
        Mage::setIsDeveloperMode(true);
    }
    
ini_set('display_errors', 1);

Now open the admin and try to save the config, this will show real error if there anythnig.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.