0

VirtualAlloc() failed: [0x00000008] Not enough memory resources are available to process this command.

VirtualAlloc() failed: [0x00000008] Not enough memory resources are available to process this command.

PHP Fatal error: Out of memory (allocated 1218445312) (tried to allocate 134217728 bytes) in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/src/Composer/DependencyResolver/RuleSet.php on line 90

While installing data migration tool using composer.

I have set the memory_limit=-1 in php.ini file.

9
  • If you're using command line try to put before the command memory_limit=-1 or COMPOSER_MEMORY_LIMIT=-1 ex: COMPOSER_MEMORY_LIMIT=1 composer update
    – Rui Silva
    Aug 12, 2020 at 10:54
  • @RuiSilva I did it but the same issue is arising. Aug 12, 2020 at 13:06
  • Then, do your machine have enough resources by itself?
    – Rui Silva
    Aug 12, 2020 at 16:41
  • @RuiSilva How to check resources? Aug 13, 2020 at 7:01
  • I don't know how to do that in command line tbh, I usually use massiveGRID e can easily check, but if you have a provider you should have the specs somewhere or can ask him, you can even expose this situation to him and maybe try to increase the limits on the provider side even if just for testing
    – Rui Silva
    Aug 13, 2020 at 9:27

1 Answer 1

0

faced same problem the solution is: 1)download the VC15 x64 Thread Safe (2020-Oct-01 13:06:05) zip file for php 7.2. 2)make a folder called php72 on dekstop. 3)copy all files from php zip folder and paste into php72 folder. 4)rename php.ini-development to php.ini. 5)enable all extensions in php.ini file. 6) save php.ini and run this command from cli.

"C:\Users\youruser\Desktop\php72\php.exe" -d memory_limit=-1 "C:/ProgramData/ComposerSetup/bin/composer.phar" update

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.