0

After update Magento version to 2.3.5-p1 and Elasticsearch to the 6.8.11 vesrions I got error message on the product catalog page

[{"type":"illegal_argument_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [updated_at] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}]

This is happens because of default sorting by updated_at field which type is "text" inside elasticsearch index. Could someone help on this? Setting fielddata is not an option as I understand, because magento will created new elasticsearch indexes after magento reindex. Thank you.

0

Attribute which was created had type "text","boolean" and also these two options Use in Layered Navigation and Use in Search Results Layered Navigation is set to “Yes”. On setting these two values to "No", Fixed the issue. Try changing, "is_filterable" field in "catalog_eav_attribute" table

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.