I'm getting the following error after i upgrade magento version to 2.3.5 and try to run php bin/magento setup:upgrade

Auto Increment column do not have index. Column - "value_id", table - "catalog_product_entity_text"

I tried to add an index as follow in catalog_product_entity_text table but still get the same error message.

Action  Keyname Type    Unique  Packed  Column  Cardinality Collation   Null    Comment
Edit Edit   Drop Drop   value_id    BTREE   Yes No  value_id    1524    A   No  
  • Have you tried to add the autoincrement index?
    – Rus0
    Aug 6, 2020 at 5:22
  • i just tried that, but still showing up the same error. Is is possible some kind of cache i need to clean before i run php bin/magento setup:upgrade again? Aug 6, 2020 at 18:52
  • is it a open source or commerce edition? and also can you update your question with the result of the query: show create table catalog_product_entity_text;
    – Rus0
    Aug 6, 2020 at 19:15

1 Answer 1


Have you added a constraint to it? Like:

<constraint xsi:type="primary" referenceId="PRIMARY">
        <column name="entity_id"/>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.