10

I am using magento 1.9 during the setup of paypal at store i am getting an error

Billing address request is not enabled for merchant (#11601: Request for billing address failed).###

I am stuck on this and i have tried every thing. so please any one can help me in this problem

  • Have you gone into your Paypal account and set this up? It's not a Magento issue until it has been enabled. – Fiasco Labs Aug 11 '14 at 14:22
  • Any idea where to set this? I've been trying for literally years to get this setting to work, PayPal support don't even seem to know what I'm talking about and I can't find the setting in live or sandbox. Other posts on SO suggest that it can only be enabled by PayPal staff - but they have never heard of it. – benz001 Dec 23 '14 at 1:08
8

I had this problem and I changed this in System>Configuration>payment methods>Paypal express checkout (configure)>Basic Settings - PayPal Express Checkout>advanced settings>require customer’s billing address. Set this to No

My example is in my site www.realleather.com.au

2

I had this issue as well and called PayPal support several times. Finally, a support representative said he turned the option on in our account, but I am still seeing the error.

I found this page explaining error code #11601:

https://www.paypal-knowledge.com/infocenter/index?page=content&id=FAQ2035&expand=true&locale=en_US

The issue is regarding the option SetCustomerBillingAgreement, which initiates a billing agreement and has been deprecated since v54.0 of the API (view Merchant API Release Notes).

We are on Magento 2.1.7 and recently billing address information stopped being returned from PayPal API requests - the Require Customer's Billing Address option seemed promising.

I am going to leave the Stores > Configuration > Sales > Payment Methods > PayPal Express Checkout > Advanced Settings > Require Customer's Billing Address option set to No and look further into it.

0

As I'm using Magento v1.9, I tried the same but it seems not yet fixed, the issue is same. Sales->Paymentmethods->PayPal Payment Solutions->Configure->Required PayPal Settings->Basic Settings->Advanced Settings->Require Customer's Billing Address set as "No"

Any Help??

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.