1

I am having problem when trying to upgrade in my dev server from Magento 2.3.5-p1 to 2.4.0 with composer.

I tried this:

composer require magento/composer-root-update-plugin=~1.0 --no-update
composer update
cp composer.json composer.json.bak
composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition=2.4.0 --no-update
composer update

After last

composer update

I get error:

magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.

I have in server php 7.3 version. I even tried with php 7.0. Couldn't make it work

What I do wrong please?

1
  • 1. check first is your composer.lock is updated. 2. Run search thru files and check is any of your module have old dependency for Magento framework 100.x and 3. composer clear-cache
    – BartZalas
    Aug 2, 2020 at 0:21

2 Answers 2

3

Check if your composer.json doesn't have any specific restriction to the magento/framework, if you find something you can remove it. Then run these commands below.

rm composer.lock
composer update -vvv

If it doesn't work, I recommend changing your composer.json to be similar to the native Magento 2.4 composer.json file.

1
  • 1
    Worked! Thank you!
    – G. G.
    Aug 3, 2020 at 18:27
1

Upgrading Magento 2.3.5 to Magento 2.4 Requirement:

Magento 2.4 support PHP 7.4 as per its offical document so before going to upgrade set require php version.

If you are planning to upgrade Magento 2.3.5-p1 to Magento 2.4, there are few changes that you need to do in your composer.json.

Run below command step by step to upgrade Magento 2.3.5 to Magento 2.4:

1-> cp composer.json composer.json.bak (this command create backup of composer.json. If you using windows, you can copy and paste the compose.json to create a backup copy)

2-> composer require magento/product-community-edition=2.4.0 --no-update

Now open composer.json file and do following required changes in version manually:

(a) "friendsofphp/php-cs-fixer": "~2.16.0"

(b) "magento/magento2-functional-testing-framework": "^3.0"

(c) "pdepend/pdepend": "~2.7.1"

(d) "phpmd/phpmd": "^2.8.0"

(e) "phpstan/phpstan": ">=0.12.3 <=0.12.23"

(f) "phpunit/phpunit": "^9"

(g) "sebastian/phpcpd": "~5.0.0"

(h) "squizlabs/php_codesniffer": "~3.5.4"

(4) Run following command:

composer update

(5) Clear cache and regenerate code.

php bin/magento cache:clean
 
rm -rf var/cache/*
 
rm -rf var/page_cache/*
 
rm -rf generated/code/*
 
php bin/magento setup:upgrade
  
php bin/magento setup:di:compile
  
php bin/magento setup:static-content:deploy -f

(6) Last and final, disable Maintenance Mode

php bin/magento maintenance:disable

After completing this command, you have to run Magento setup upgrade, di compile , deploy command also .

TESTED AND WORKING PROPERLY WITHOUT ERRORS

If you get any issue with the upgrade, please comment below so I can help you.

For Reference -

1-> https://www.codextblog.com/magento-2/upgrade-magento-version-2-3-x-2-4-0/

2-> https://github.com/magento/magento2/issues/29350

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.