1

Run: composer update

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

- magento/product-enterprise-edition 2.4.0 requires pelago/emogrifier ^3.1.0 -> satisfiable by pelago/emogrifier[3.1.x-dev, v3.1.0] but these conflict with your requirements or minimum-stability.
- magento/product-enterprise-edition 2.4.0 requires pelago/emogrifier ^3.1.0 -> satisfiable by pelago/emogrifier[3.1.x-dev, v3.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for magento/product-enterprise-edition 2.4.0 -> satisfiable by magento/product-enterprise-edition[2.4.0].

Help me to resolve this error.

0

First of all, check your server requirements using these commands below.

curl -O https://files.magerun.net/n98-magerun2.phar && chmod +x ./n98-magerun2.phar
./n98-magerun2.phar sys:check

If everything is good to go, you can run these commands to remove the cache and run the composer update again.

composer clearcache
rm composer.lock
composer update -vvv

If it doesn't work I recommend checking your composer.json comparing to the original one from Magento 2.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.