0

I have installed fresh Magento 2.3.2, but add to cart is not working even I have changed the secure and unsecure base url in core_config_data table from http://localhost/magento2/ to http://127.0.0.1/magento2 . There is not showing any error in browser console also.

Below are the details of environment I am using to run Magento 2.3.2:

OS: Ubuntu 19.10

PHP version: 7.2.31

Mysql version: 5.7.30

Browser: Google Chrome / Firefox

Please find the screenshot below for the reference.

  • Mysql version

enter image description here

  • PHP Info

enter image description here

  • Database core_config_data table:

enter image description here

Please suggest.

Thanks in advance.

  • Debug log

enter image description here

  • System log

enter image description here

  • remove var/cache and var/view_preprocessed folder and run all commands again – Mohit Patel Jul 30 at 18:55
  • 1
    Are you able to see any error in your logs, try to set the developer mode and check the network for request and response, more more error info uncomment error reporting from Bootstrap file and share error with us for more detail analysis. – Ashish Ranade Jul 30 at 19:42
  • @MohitPatel, Thanks for the reply, I did the same but issue is still there. I run the the below commands sequentially. rm -rf var/cache/ generated/ pub/static/frontend/ var/page_cache/ var/view_preprocessed/ php bin/magento setup:di:compile php bin/magento c:f chmod -R 777 var/ generated/ pub/ – Aatif Jul 31 at 4:58
  • you try to setup , deploy and reindex command – Mohit Patel Jul 31 at 5:01
  • Hello @AshishRanade, Thanks for the support, I did the same as you instructed. I set the mode to developer, uncommented the ini_set('display_errors', 1); but still not fixed. Please find the log files screenshot update above. – Aatif Jul 31 at 5:06
0

I suggest to use x-debug to understand if php is called at the time of clicking on the add to cart button.

Also for debugging on magento 2 frontend I suggest you install this package that helps you understand how the frontend part magento 2 is structured.

If even so you can't find the solution I would move to the nginx / apache side checks to find out if there is an incorrect configuration of the redirect settings.

Have you installed varnish? In that case you should also check the varnish.vcl settings

Cheers

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.