2

I am upgrading Magento 2.3.5-p1 to Magento 2.4.0. I followed below steps

composer require magento/composer-root-update-plugin=~1.0 --no-update

composer update

cp composer.json composer.json.bak

composer remove magento/product-community-edition --no-update

composer require magento/product-community-edition=2.4.0 --no-update

composer update

but it's showing error after run composer update command

root@server:/var/www/html# composer update
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information                                                       Updating dependencies (including require-dev)         
Your requirements could not be resolved to an installable set of packages.



Problem 1
    - magento/magento2-functional-testing-framework 2.4.5 requires codeception/codeception ~2.3.4 || ~2.4.0  -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4].
    - magento/magento2-functional-testing-framework 2.4.5 requires codeception/codeception ~2.3.4 || ~2.4.0  -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4].   
           
  - codeception/phpunit-wrapper 7.7.0 requires phpunit/phpunit 7.5.* -> satisfiable by phpunit/phpunit[7.5.0, 7.5.1, 7.5.10, 7.5.11, 7.5.12, 7.5.13, 7.5.14, 7.5.15, 7.5.16, 7.5.17, 7.5.18, 7.5.19, 7.5.2, 7.5.20, 7.5.3, 7.5.4, 7.5.5, 7.5.6, 7.5.7, 7.5.8, 7.5.9] but these conflict with your requirements or minimum-stability.
    - codeception/phpunit-wrapper 7.6.1 requires phpunit/phpunit >=7.1 <7.6 -> satisfiable by phpunit/phpunit[7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.1.5, 7.2.0, 7.2.1, 7.2.2, 7.2.3, 7.2.4, 7.2.5, 7.2.6, 7.2.7, 7.3.0, 7.3.1, 7.3.2, 7.3.3, 7.3.4, 7.3.5, 7.4.0, 7.4.1, 7.4.2, 7.4.3, 7.4.4, 7.4.5, 7.5.0, 7.5.1, 7.5.10, 7.5.11, 7.5.12, 7.5.13, 7.5.14, 7.5.15, 7.5.16, 7.5.17, 7.5.18, 7.5.19, 7.5.2, 7.5.20, 7.5.3, 7.5.4, 7.5.5, 7.5.6, 7.5.7, 7.5.8, 7.5.9] but these conflict with your requirements or minimum-stability.

    - Installation request for magento/magento2-functional-testing-framework 2.4.5 -> satisfiable by magento/magento2-functional-testing-framework[2.4.5].

Due to the limit of characters. I put my full error on this link https://newtextdocument.com/304df9aad8

I have fixed above issue by changes in composer.json file

"require-dev": {
        "allure-framework/allure-phpunit": "~1.2.0",
        "dealerdirect/phpcodesniffer-composer-installer": "^0.5.0",
        "friendsofphp/php-cs-fixer": "~2.16.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento-coding-standard": "*",
        "magento/magento2-functional-testing-framework": "^3.0",
        "pdepend/pdepend": "~2.7.1",
        "phpcompatibility/php-compatibility": "^9.3",
        "phpmd/phpmd": "^2.8.0",
        "phpstan/phpstan": ">=0.12.3 <=0.12.23",
        "phpunit/phpunit": "^9",
        "sebastian/phpcpd": "~5.0.0",
        "squizlabs/php_codesniffer": "~3.5.4"
    },

But now I am getting below error.

Problem 1
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.19) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.19) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.19) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.19) does not satisfy that requirement.
    - vnecoms/module-pdfpro 2.3.17 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.0 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.1 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.10 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.11 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.12 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.13 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.14 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.15 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.16 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.17 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - vnecoms/module-pdfpro 2.3.2 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.2.1 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.2.2 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.2.3 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.2.4 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.3 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.4 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.5 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.6 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.7 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.8 requires magento/framework ^102.0 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.2-p2, 102.0.3, 102.0.2, 102.0.1, 102.0.0].
    - vnecoms/module-pdfpro 2.3.9 requires magento/framework ^102.0.3 -> satisfiable by magento/framework[102.0.5, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 102.0.3].
    - Can only install one of: magento/framework[102.0.5-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.4-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.5, 103.0.0].
    - Can only install one of: magento/framework[102.0.3-p1, 103.0.0].
    - Can only install one of: magento/framework[102.0.4, 103.0.0].
    - Can only install one of: magento/framework[102.0.3, 103.0.0].
    - Can only install one of: magento/framework[103.0.0, 102.0.5].
    - magento/product-community-edition 2.4.0 requires magento/framework 103.0.0 -> satisfiable by magento/framework[103.0.0].
    - Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].
    - Installation request for vnecoms/module-pdfpro ^2.3 -> satisfiable by vnecoms/module-pdfpro[2.3.17, 2.3.0, 2.3.1, 2.3.10, 2.3.11, 2.3.12, 2.3.13, 2.3.14, 2.3.15, 2.3.16, 2.3.2, 2.3.2.1, 2.3.2.2, 2.3.2.3, 2.3.2.4, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9].

I am using PHP 7.3

5
  • do you have upgraded your server?
    – Waqar Ali
    Jul 30, 2020 at 9:41
  • which thing I need to upgrade in the server. I am using PHP 7.3 using. Jul 30, 2020 at 9:48
  • what about MYSQL?
    – Waqar Ali
    Jul 30, 2020 at 9:50
  • I have solve this issue check updated questions @WaqarAli Jul 31, 2020 at 5:46
  • Ran into similar situation when upgrading from Magento CE 2.2.6 to 2.4.1, manually updating composer.json has helped to resolve 'composer update' errors. Ran composer require magento/composer-root-update-plugin=~1.1 --no-update as well.
    – cnu
    May 3, 2021 at 2:36

4 Answers 4

3

Best,

I have found out my Composer version was not the latest. After updating Composer to the latest version i was able to finish the magento upgrade to 2.4.0

So simply run composer selfupdate and it will work.

Best regards...

1
  • it's showing me below error after composer update Problem 1 - The requested package magento/product-community-edition (locked at 2.3.5-p1, required as 2.4.0) is satisfiable by magento/product-community-edition[2.3.5-p1] but these conflict with your requirements or minimum-stability. Aug 4, 2020 at 6:55
0

Im not very experienced, so better advice from others may follow.

I would say Check in your composer.json file

In there will be "phpunit/phpunit" listed with a version number after,

which is Version Constrain / limiting its upgrade, and causing the error message above "these conflict with your requirements or minimum-stability."

So you may have to change the version number. This link may be helpful. https://getcomposer.org/doc/articles/versions.md#writing-version-constraints

1
  • I have solve this issue check updated questions Jul 31, 2020 at 5:46
0

Best,

Same issue here

composer update Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - magento/magento2-functional-testing-framework 2.5.3 requires codeception/codeception ~2.3.4 || ~2.4.0 -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4]. - magento/magento2-functional-testing-framework 2.5.3 requires codeception/codeception ~2.3.4 || ~2.4.0 -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4]. - codeception/codeception 2.4.0 requires codeception/phpunit-wrapper ^6.0|^7.0 -> satisfiable by codeception/phpunit-wrapper[6.8.1, 6.0.0, 6.0.1, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.17, 6.0.18, 6.0.19, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.5.0, 6.5.1, 6.6.0, 6.6.1, 6.7.0, 6.7.1, 6.8.0, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 7.0.6, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.2.0, 7.3.0, 7.3.1, 7.3.2, 7.4.0, 7.5.0, 7.6.0, 7.6.1, 7.7.0, 7.7.1, 7.7.2, 7.8.0].

4
  • How can I solve this issue Jul 30, 2020 at 17:49
  • I have solved this issue check updated questions Jul 31, 2020 at 5:46
  • Can you explain in simple steps how you did solve the issue? So it is easy for (me) everyone to resolve this problem?
    – user45617
    Jul 31, 2020 at 9:57
  • Check updated question Jul 31, 2020 at 12:07
0

Hi I recently upgrade successfully from Magento 2.3.3 to Magento 2.4.3 I have composer update issue too.

I resolved this by doing following these steps

if you have upgraded to composer 2x, please downgrade to composer 1x first

sudo composer self-update --1

Then run composer update using php7.1 (for magento 2.3):

/usr/bin/php7.1 -d memory_limit=-1 /usr/local/bin/composer update --no-plugins

Then run magento upgrade command After upgrade to magento 2.4.3, then you need upgrade composer to 2x and run this command using php7.4 for magento2.4.3:

/usr/bin/php7.4 -d memory_limit=-1 /usr/local/bin/composer update --no-plugins

It will update successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.