0

I am using ubuntu 18.04 with PHP 7.3 and MySQL 5.7 Magento 2.3.5 is working fine what are requirements for Magento 2.4

3 Answers 3

1

Magento 2.4 is just released on July 28, 2020

Here are the Main Points I have extracted from Magento DevDocs

Operating System

Magento 2.4 on only work on Linux distributions Like

  • Linux (RHEL)
  • CentOS
  • Ubuntu
  • Debian

Magento 2.4 is not supported on

  • Windows OS
  • Mac OS

Apache

  • Magento 2.4 will work on Apache 2.4

PHP

  • Magento 2.4 will work on PHP 7.3 and 7.4
  • It is recommended to use PHP 7.2 for testing
  • PHP 7.4.2 has some bugs which cause some messages to not render properly

MYSQL

  • Magento 2.4 will work on MySQL 8.0

You can read Full Requirements Here

0

Magento will run anywhere with LEMP/LAMP stack.

but add 2Gb or 4Gb RAM for ELK stack extra memory.

or use AWS ELK remote service

0

On the screenshot You can see which version was required for Magento2.4 enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.