1

In admin page, I turned on the mode Manage Stock to Yes. After reindex, when I go to product list page, it got an error like this:

enter image description here

I go to var/log to check what happened, and saw this line:

Can't check requested quantity for products without Source Items support

After search many post in here, I have to temporary fix by delete record in table ui_bookmarks. But it just for a moment, it will be error again later.

How I can fix this?

Thank you!

  • did you find any solution for this? – Magento2 Devloper Jul 29 at 9:10
  • after you fix the ui_bookmark and get back in, use the Columns view editor and uncheck Quantity and Saleable quantity and see if that helps – bjornredemption Jul 30 at 4:39
  • not working on that way – Magento2 Devloper Jul 30 at 14:52
0

Refer this.

Can't check requested quantity for products without Source Items support issue on 2.3.1

Hope it will helps.

If it is not still not fixed then you have to comment the code that added custom column one by one and check which column is use quantity to fetch.

| improve this answer | |
  • Hi I checked but we didn't use any third-party extension. – Magento2 Devloper Jul 29 at 9:53
  • Is there any new product type added or may be it could be issue with product. we cannot check without checking the log or code – Amitkumar solanki Jul 29 at 10:17
  • No any other product type added also debug and system log in the same error without file path. – Magento2 Devloper Jul 29 at 10:59
0

which magento version? If magento is >2.3 and you have enabled the MSI (new inventory manager) check if you have the inventory_stock_1 view, not table but view.

Also check in your config.php if all module of inventory are enabled; if so follow those steps for fix your issue.

Steps:

This procedure generate the correct inventory stock view

Cheers

| improve this answer | |
  • Hi I checked all is fine but still not working – Magento2 Devloper Aug 3 at 10:38
  • no wait, it's not just a check. My comment it's a procedure to do – Riccardo Ugolini Aug 3 at 11:22
  • Yes I did as well – Magento2 Devloper Aug 3 at 11:53
  • the result of this query? select * from catalog_product_entity where sku not in (select sku from inventory_source_item); – Riccardo Ugolini Aug 4 at 13:02
  • if the result of the query above is different from 0 you have found your problem – Riccardo Ugolini Aug 4 at 13:07
-1

Are you running Magento 2.3?

New code from Magento 2.3

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Catalog:etc/product_types.xsd">
    <type name="simple" isQty="true" />
    <type name="virtual" isQty="true" />
</config>

Check vendor\vendor\magento\module-catalog-inventory\etc\product_types.xml

So for your custom product type also add isQty="true" in /etc/product_types.xml

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.