6

We've all had this at one point or another, I've looked around and cannot find anything obvious.

How can you disable the pop up window that is displayed when you login to the admin panel when there are new messages?

Note: I do not want to disable the message feature completely, I just don't want to have the pop-up appear when I login.

  • Did you find a solution for your question? I am talking about your Note: I do not want to disable the message feature completely, I just don't want to have the pop-up appear when I login. – kanenas Jun 9 '16 at 9:09
4

Method 1

Under:

System > Configuration > Advanced > Advanced > Disable Modules Output simply set Mage_AdminNotification to “Disable”.

Method 2

The previous method works fine but potentially, a user can re-enable these easily. To make the change a bit more difficult to undo, we can disable the module from the modules XML files. If we already have a custom module, we can simply add:

<Mage_AdminNotification>
    <active>false</active>
</Mage_AdminNotification>

To our module XML file. A complete example could look like this:

<?xml version="1.0" encoding="UTF-8"?>
<config>
    <modules>
        <MageBase_Custom>
            <active>true</active>
            <codePool>local</codePool>
            <depends>
                <Mage_Core />
                <Mage_Cms />
            </depends>
        </MageBase_Custom>
        <Mage_AdminNotification>
                <active>false</active>
        </Mage_AdminNotification>
    </modules>
</config>

Reference LINK

3

From http://www.nyssasutherland.com/how-to-disable-annoying-magento-admin-popup-messages/

Simply login, go to System -> Configuration -> Advanced and change the “Mage_AdminNotification” drop down to disabled.

  • Does it disable the inbox feature? – SR_Magento Aug 8 '14 at 18:57
3

If you do not want to disable the message feature completely, You should not disable Mage_AdminNotification.

To just disable the annoying popup you should rewrite Mage_Adminhtml_Block_Notification_Window. File path is app/code/core/Mage/Adminhtml/Block/Notification/Window.php. You should override canShow() function like this:

class Your_Module_Block_Notification_Window extends Mage_Adminhtml_Block_Notification_Window
{
    public function canShow()
    {
        return false;
    }
}

Here you can find more on overriding in magento.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.