I have xdebug set up in phpstorm. However every time I load my Magento 2 app the script get.php opens 3 times in the debugger and breaks. I also get the error

"The script '/pub/get.php' is outside the project. Click to set up path mappings."

My files are on the localhost, using MAMP. I'm just starting with xdebug, and can't get this configured.

1 Answer 1


Please reset all phpstrom's xdebug setting and follow these steps: https://www.jetbrains.com/help/phpstorm/configuring-xdebug.html#integrationWithProduct from the official documentation.

Settings/Preferences dialog Ctrl+Alt+S, select Languages & Frameworks | PHP.| Servers unselect Use path mappings for localhost. Xdebug’s default debugging port has changed from 9000 to 9003 in xdebug3. please consider that as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.