0
[root@test]# php bin/magento indexer:reindex
Design Config Grid index has been rebuilt successfully in 00:00:00
Customer Grid index has been rebuilt successfully in 00:00:00
Product Flat Data index has been rebuilt successfully in 00:00:46
No such entity.
No such entity.
No such entity.
Catalog Rule Product index has been rebuilt successfully in 00:00:00
Product EAV index has been rebuilt successfully in 00:00:14
Stock index has been rebuilt successfully in 00:00:03
Product Price index has been rebuilt successfully in 00:00:02
Catalog Product Rule index has been rebuilt successfully in 00:00:00
Catalog Search index has been rebuilt successfully in 00:00:05

Any help thanks.

  • Instead of changing the question, you can always update the question with more details. So in case if someone has posted an answer related to earlier query make sense. Thanks. – Bhaumik Upadhyay Jul 20 at 10:04
1

When the allocated memory size for a temporary table will be greater than 20% of innodb_buffer_pool_size, the error message is written to the Magento log.

Can you please update the value for batchRowsCount to 10000 in Vendor_Module/etc/di.xml file of catalog_category_product (Category Products) indexer.

For more details related to Exceeding allocated memory size issue read Magento official document here.

For instance:

<type name="Magento\Catalog\Model\Indexer\Category\Product\Action\Full">
    <arguments>
        <argument name="batchRowsCount" xsi:type="number">10000</argument>
        <argument name="batchSizeManagement" xsi:type="object">Magento\Catalog\Model\Indexer\CategoryProductBatchSize</argument>
    </arguments>
</type>

Hope this helps!

| improve this answer | |
  • Where is located vendor_module/etc/di.xml – zus Jul 16 at 1:32
  • The default config file resides at Magento/Catalog/etc/di.xml for the configured object Magento\Catalog\Model\Indexer\Category\Product\Action\Full. – Bhaumik Upadhyay Jul 16 at 1:35
  • Yes, I updated batch size 1000 then run reindex command still getting error no such entity error. Anything else I need to update? – zus Jul 16 at 1:37
  • Try running the php bin/magento s:di:c compilation command and then run the reindex command again and check. – Bhaumik Upadhyay Jul 16 at 1:45
  • Yes, I run this command, still my issue retain. – zus Jul 16 at 1:48
0

SOLVED: There was store on 'stores' table that was relating with an 'store_group' that wasn´t there. Changed the ID and reindex worked fine.

Note : remove values from the table design_change

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.