1

We have two sites running on one installation of Magento 1.8.1. The .com is for USA orders (separate fulfillment in US) and the .ca is for Canadian orders (separate fulfillment in CA).

The .com site (the "Default Config") has a default country (in System/Configuration/General) of only United States, and the .ca site has a default country of only Canada. See below screenshots...

.com configuration

.ca configuration

The problem is when we try to edit or create a new customer record (Customers/Manage Customers/Edit or Add New Customer) the Addresses country pulldown is only showing "United States" and not "Canada".

edit customer

add new customer

If we also select "Canada" as a default country (in System/Configuration/General) it will add "Canada" to the pulldown list. The problem is that if we do this our shopping cart (and checkout) gives the visitor the option of selecting "United States" or "Canada" from both the .com and .ca sites. We only want "United States" in the .com site and "Canada" in the .ca site.

Is there a setting or something that will get "Canada" and "United States" to show in customer address country pulldown without adding both to shopping cart and checkout?

Thanks for your help in advance!

2 Answers 2

1

Don't use the default config as the config of one of the sites. If you created 2 websites configure the countries in both websites and don't use the defaults or this issue will happen. If you did not, create the 2 separate websites and configure them separately.

It should be something like this

Default: USA - Canada - Anything you want to use

  • Store 1: Unselect "Use default" and select Canada in Country select
  • Store 2: Unselect "Use default" and select USA in Country select

This should give you the ability to create customers from the admin with any country selected in the Default configuration.

2
  • That worked perfectly! Thanks for your help!
    – Surge Labs
    Aug 8, 2014 at 20:55
  • Please mark the question as accepted.
    – mbalparda
    Aug 9, 2014 at 6:59
1

You need to change in System > Configuration > General > Allow Countries > and include the countries you want to show in admin. Then the drop down menu should appear correctly for the countries you have picked.

I hope it solves your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.