After a fresh Magento 2.3.5 install, my admin dashboard is partially loaded. There is a spinning element that appears over it while the entire page is disabled. I have attached a picture. Please can someone tell me how I can solve this problem? Thanks.

enter image description here

  • you run all commands Jul 10, 2020 at 12:01
  • @MohitPatel, which commands, please?
    – Efosa
    Jul 10, 2020 at 12:04
  • check my answer Jul 10, 2020 at 12:05
  • Ok thanks @MohitPatel. Let me try.
    – Efosa
    Jul 10, 2020 at 12:05

1 Answer 1


you are run all command like :-

php bin/magento setup:upgrade
php bin/magento setup:di:compile    
php bin/magento setup:static-content:deploy -f
php bin/magento c:f    
php bin/magento c:c

And second options :-

Go to your app/etc and open the di.xml file

Find this class Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink and replace this Magento\Framework\App\View\Asset\MaterializationStrategy\Copy


  • Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink and Magento\Framework\App\View\Asset\MaterializationStrategy\Copy already exist in the di.xml. Please which one is replacing which?
    – Efosa
    Jul 10, 2020 at 12:11
  • okay you only command Jul 10, 2020 at 12:13
  • I ran the shell commands at the root of the magento directory, but did not work.
    – Efosa
    Jul 10, 2020 at 12:17
  • try this command php bin/magento config:set web/secure/use_in_adminhtml 1 Jul 10, 2020 at 12:18
  • When I run php bin/magento setup:upgrade I get PHP Fatal error: Uncaught Error: Undefined class constant 'PDO::MYSQL_ATTR_SSL_KEY' in C:\xampp\htdocs\magento2\setup\src\Magento\Setup\Model\ConfigOptionsList.php:179 Stack trace:
    – Efosa
    Jul 10, 2020 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.