0

After installing a module, it appears in my back office but when I click on it, I get this message that appears:

Extension bug

  • It seems that table associated with the module is not there. Have you run the necessary commands ? – Anuraag Jul 9 at 14:58
  • @Tanmay I run 2 commands : php bin/magento setup:upgrade and php bin/magento setup:static-content:deploy – brooll Jul 9 at 15:11
  • It seems table is not created. Which command you have executed? – Prashant Valanda Jul 9 at 15:13
  • @PrashantValanda php bin/magento setup:upgrade and php bin/magento setup:static-content:deploy – brooll Jul 9 at 15:16
  • try removing generated and run di:compile then deploy it will solve ur issue. i can see something related to interception in that big error log since am rplyimg from phone so i cant see the complete log – Pramod Jul 10 at 18:21
1

Go to Db open table setup_module delete row of just installed extension name from table.

Then run below command:

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy -f

php bin/magento cache:flush

| improve this answer | |
  • don't you think compilation command is also needs to be run ? – Anuraag Jul 9 at 15:47
  • If your environment in production mode then compilation command require otherwise not – Prashant Valanda Jul 10 at 10:23
0

You have an issue with the extension DPDFrance_ShippingM2 module. A table dpd_option is created from this extension that does not do not exist at your database that why you are getting error.

First, You have to disable that extension php bin/magento module:disable DPDFrance_ShippingM2 and after that run extension php bin/magento setup:upgrade and php bin/magento setup:static-content:deploy -f.

You have to ci

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.