0

As the title says, I'm experiencing a rather strange issue on my Magento instance (2.3.5-p1).

We have two languages, English and French, and thus have a language switcher allowing users to switch back and forth. This works as expected on every pages on the site except on the Home Page (as far as I've tested).

You can try this live by going to shop.icrc.org.

  1. Switch the language to "Français". The page reloads, but the language is not updated.
  2. Naviguate to any other page, and the site should now be in French.
  3. From there, go back to the Home Page and the site is back in English.

What is really strange is that:

  • this behavior does not exist on our staging environment, which is also a 2.3.5-p1 instance.
  • If you take a look at the Cookies set by Magento, you'll see that the one named store (which I suppose is used to indicate the current store language) is properly set even on the Home Page to the selected language (i.e. It exists with a value of fr after changing the language to "Français"). It's as if the Home Page did not care about the value of this cookie for whatever reason...

Alright, so... I have no idea where to look or investigate to try and fix this problem...

Would anyone have any clue as to what could cause this behavior? Even a somewhat vague intuition would be fine by me... Is this a back-office configuration issue? A code issue? A server misconfiguration? I'll take anything :D

0

Well...

Turns out it was as simple as going to the back-office and hitting the "Flush Magento Cache" button in the Cache Management page -_-'

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.