0

Updated Magento to 2.2.11 for new payment processor extension. Extension requires everything to go through https so I enabled that for the domain (shared hosting). Compiled, deployed, reindexed, cleaned up caches. However the frontend continues to use http and backend only accessible (via http) if i clear cookies before every session.

Guides instruct me to change values in store/system config/web to have both secure and unsecure url point to https. I am unable to change these as putting in the https url and trying to save changes results in the following error:

The input appears to be a DNS hostname but cannot match TLD against known list; The input does not appear to be a valid URI hostname; The input does not appear to be a valid local network name

I've manually edited the base_url values in the db but when I load store/config/web these changes are not reflected. I am at a loss as to where it's pulling the data on the admin backend since it's ignoring the db values.

db config: db config

store/config/web/unsecure and secure urls: store/config/web

store/config/web cookie settings: enter image description here

You can tell this isn't my day job but I am managing the e-com for my dad since his budget doesn't allow someone actually qualified. Any help would be most welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.