0

I've got a problem with a website that i have inherited from another developer, it's Magento 2.3.2 with quite a few extensions installed... The majority of the extensions are installed at /app/code - so manually installed via FTP but 1 extension is installed at /vendor - so installed via composer and the server doesn't have composer installed?

I am guessing the previous dev started work on the site on a server with composer and then moved it to a server without composer... anyway the 1 extension in the /vendor folder (a Sagepay payment processing extension) is causing problems and needs updating or removing and the new version installing via FTP - but how??

0

You can use composer just by adding the composer.phar file to your project root directory (where composer.json and composer.lock is located).
Then you can use it like this:

<path_to_project_root>/composer.phar remove VendorName/VendorExtensionRepository

Before that you should disable the extension by using the Magento built-in command line commands:

php bin/magento module:disable <ExtensionProvider_ExtensionName> --clear-static-content
php bin/magento setup:upgrade

Here you can find further information.

| improve this answer | |
  • That's the confusing thing - site already has a composer.phar file in the root but 'composer --help' returns command not found (so no composer installed on the server?) – Tony Ryan Jun 23 at 13:39
  • Instead of composer --help try ./composer.phar --help (in the directory of the .phar file) – MichiP Jun 23 at 13:44
  • Thanks Michael - yes that worked... I'll try the un-install now – Tony Ryan Jun 23 at 14:20
  • You're welcome! Don't forget to accept the answer if it worked for you :) – MichiP Jun 24 at 13:23
  • Hi Michael I've accepted your answer as it should have worked fine but unfortunately I got errors about another extension when I tried to remove the payment extension (git not found error I think) and things went pear shaped from there... I did however bite the bullet and just overwrote the files in /vendor/<module name> with the updated files and ran setup:upgrade and it seemed to work.. not ideal but will do for now as the site in question is due a full upgrade / rebuild. Again many thanks – Tony Ryan Jun 24 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.