0

So we installed a fresh M2.3.5

and are seeing a conflict between these 2:

Magento\Email\Model\Template\SenderResolver
Dotdigitalgroup\Email\Model\Email\DotdigitalSenderResolver

Now we have never installed anything from Dotdigitalgroup.

Question: what is the fastest way of finding out to what extension or source the code from Dotdigitalgroup comes from?

1
1

Dotdigitalgroup modules installed by default with the Magento 2 instance.

Installed directory : magento/vendor/dotmailer

Three modules relate to dotdigital as follows which you can disable

Dotdigitalgroup_Email

Dotdigitalgroup_Chat

Dotdigitalgroup_Enterprise

Below module disable command will surely help you

php bin/magento module:disable --clear-static-content Dotdigitalgroup_Email Dotdigitalgroup_Chat Dotdigitalgroup_Enterprise

3
  • Interesting then that there is a DEFAULT conflict ... feels very silly – snh_nl Jun 19 '20 at 15:25
  • What does DotDigital do? – snh_nl Jun 19 '20 at 15:25
  • I only needed to disable php bin/magento module:disable Dotdigitalgroup_Chat – snh_nl Aug 4 '20 at 13:52
0

I recommend removing via composer

https://github.com/yireo/magento2-replace-all/blob/50355d3133c42ec025e289a3421854f2737af7e5/composer.json#L14-L17

        "dotmailer/dotmailer-magento2-extension": "*",
        "dotmailer/dotmailer-magento2-extension-chat": "*",
        "dotmailer/dotmailer-magento2-extension-enterprise": "*",
        "dotmailer/dotmailer-magento2-extension-package": "*",

Dotmailer is email marketing

Also if third party you can use composer command to find out what's brought it in

https://stackoverflow.com/a/59975169/10121426

Use composer depends with the --tree option.

Example: say I want to see a tree structure of what packages depend on the doctrine/data-fixtures package up to the _root_ package.

composer depends --tree doctrine/data-fixtures

Output:

doctrine/data-fixtures 1.4.0 Data Fixtures for all Doctrine Object Managers
└──doctrine/doctrine-fixtures-bundle 3.3.0 (requires doctrine/data-fixtures ^1.3)
   └──__root__ (requires (for development) doctrine/doctrine-fixtures-bundle ^3.3)

Another argument is why

Example:

composer why nyholm/psr7  

Output:

justbetter/magento2-sentry  2.2.3  requires  nyholm/psr7 (^1.2)  

Full Example on one of the components above:

composer why dotmailer/dotmailer-magento2-extension-chat
dotmailer/dotmailer-magento2-extension-package  4.4.0  requires  dotmailer/dotmailer-magento2-extension-chat (1.0.1)  

composer why dotmailer/dotmailer-magento2-extension-package
magento/product-community-edition  2.3.5-p1  requires  dotmailer/dotmailer-magento2-extension-package (4.4.0) 

composer depends --tree dotmailer/dotmailer-magento2-extension-chat
dotmailer/dotmailer-magento2-extension-chat 1.0.1 Engagement Cloud for Magento 2: Chat module
└──dotmailer/dotmailer-magento2-extension-package 4.4.0 (requires dotmailer/dotmailer-magento2-extension-chat 1.0.1)
   └──magento/product-community-edition 2.3.5-p1 (requires dotmailer/dotmailer-magento2-extension-package 4.4.0)
      └──magento/project-community-edition 2.3.5-p1 (requires magento/product-community-edition 2.3.5-p1)
1
  • After doing his we still needed to disable somehow? or maybe disable before update, after remove? – snh_nl Aug 4 '20 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.