0

I was able to get the Data Migration Tool to transfer our site's data and settings from v1.9.2.1 to v2.3.5-p1.

There is one small problem that I can't figure out though.

When I view orders on the admin side, the section titled "Items Ordered" is always empty. But the order line items are in the database.

  • This returns one row as expected for this order

select * from sales_order WHERE entity_id = 77002;

  • This returns 5 rows as expected for this order

select * from sales_order_item WHERE order_id = 77002;

I am still in the early stages of learning Magento. Thank you.


Edit 1:
I ran tail on the /var/www/html/var/log/debug.log and got the following errors when refreshing the admin view order page:

[2020-06-18 15:46:22] main.CRITICAL: Type Error occurred when creating object: Magento\Framework\Filter\TruncateFilter\Result, Argument 1 passed to Magento\Framework\Filter\TruncateFilter\Result::__construct() must be of the type string, null given, called in /var/www/html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php on line 121 [] []
[2020-06-18 15:46:22] main.CRITICAL: Type Error occurred when creating object: Magento\Framework\Filter\TruncateFilter\Result [] []


3
  • Check the log file if any errors are logged. – Bhaumik Upadhyay Jun 18 '20 at 15:19
  • Did you have any custom order attributes in Magento 1? if you migrated using --auto then it might cause an error. Check your eav_attributes table in M2, remove attributes that aren't used in your M2 install. – Ricky Odin Matthews Jun 22 '20 at 17:03
  • @Ricky, thank you for your reply we are looking into what you said. I will update you when i have learned. – Don Moore Jun 22 '20 at 19:07
0

In Magento 1, there are sales_flat_order table and sales_flat_order_item table. However, in Magento 2, they are renamed to sales_order and sales_order_item. Please try to back up and run again the data migration tool

2
  • Hello, thank you for your response, after looking at it more closely i discovered that I was looking at the wrong database. All the correct tables were transferred but the order line items are still not showing up in the admin. Thank you for your help. – Don Moore Jun 22 '20 at 14:21
  • @DonMoore, you're welcome! please give me an upvote and accept my answer as a solution to help others who are in the same situation can find the right answer. – LitExtension Magento Migration Jun 23 '20 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.