0

I am facing an issue in installing magepack 2.3.2 extension for js bundling in the Magento 2.3.3 cloud environment. Is this extension supports to cloud environment?

https://github.com/magesuite/magepack

Error log:

Installing nodejs build dependencies: magepack /app/.global/bin/magepack -> /app/.global/lib/node_modules/magepack/cli.js

      > puppeteer@2.1.1 install /app/.global/lib/node_modules/magepack/node_modules/puppeteer
      > node install.js
      
      W: /app/.global/lib/node_modules/magepack/node_modules/puppeteer/lib/helper.js:91
      W:   static async releaseObject(client, remoteObject) {
      W:                ^^^^^^^^^^^^^
      W: 
      W: SyntaxError: Unexpected identifier
      W:     at createScript (vm.js:56:10)
      W:     at Object.runInThisContext (vm.js:97:10)
      W:     at Module._compile (module.js:549:28)
      W:     at Object.Module._extensions..js (module.js:586:10)
      W:     at Module.load (module.js:494:32)
      W:     at tryModuleLoad (module.js:453:12)
      W:     at Function.Module._load (module.js:445:3)
      W:     at Module.require (module.js:504:17)
      W:     at require (internal/module.js:20:19)
      W:     at Object.<anonymous> (/app/.global/lib/node_modules/magepack/node_modules/puppeteer/index.js:17:18)
      /app/.global/lib
      └─┬ magepack@2.3.2 
        ├── commander@5.1.0 
        ├── consola@2.12.2 
        ├─┬ glob@7.1.6 
        │ ├── fs.realpath@1.0.0 
        │ ├─┬ inflight@1.0.6 
        │ │ └── wrappy@1.0.2 
        │ ├── inherits@2.0.4 
        │ ├─┬ minimatch@3.0.4 
        │ │ └─┬ brace-expansion@1.1.11 
        │ │   ├── balanced-match@1.0.0 
        │ │   └── concat-map@0.0.1 
        │ ├── once@1.4.0 
        │ └── path-is-absolute@1.0.1 
        ├─┬ gzip-size@5.1.1 
        │ ├── duplexer@0.1.1 
        │ └── pify@4.0.1 
        ├── javascript-stringify@2.0.1 
        ├── jsesc@3.0.1 
        ├── lodash.merge@4.6.2 
        └─┬ terser@4.7.0 
          ├── commander@2.20.3 
          ├── source-map@0.6.1 
          └─┬ source-map-support@0.5.19 
            └── buffer-from@1.1.1 
      
      W: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: puppeteer@2.1.1 (node_modules/magepack/node_modules/puppeteer):
      W: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: puppeteer@2.1.1 install: `node install.js`
      W: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
      W: 
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.