0

I have this error on Magento 2.3.3 when I try to refund (credit memo) an order with visa (authorize.net).

[2020-06-17 05:43:44] main.DEBUG: array (   'request' =>    array (
    'payload_type' => 'createTransactionRequest',
    'merchantAuthentication' => 
    array (
      'name' => '8Hkxxxx',
      'transactionKey' => '2485P7zxxxxxx',
    ),
    'transactionRequest' => 
    array (
      'transactionType' => 'refundTransaction',
      'amount' => '3.12',
      'payment' => 
      array (
        'creditCard' => 
        array (
          'cardNumber' => '27xx',
          'expirationDate' => 'XXXX',
        ),
      ),
      'refTransId' => NULL,
      'order' => 
      array (
        'invoiceNumber' => '1000049324',
      ),
      'poNumber' => NULL,
      'customer' => 
      array (
        'id' => NULL,
        'email' => '[email protected]',
      ),
      'billTo' => 
      array (
        'firstName' => 'xx',
        'lastName' => 'xx',
        'company' => '',
        'address' => 'xxN Riverside Ave',
        'city' => 'St Clair',
        'state' => 'MI',
        'zip' => 'xx',
        'country' => 'US',
      ),
      'shipTo' => 
      array (
        'firstName' => 'xx',
        'lastName' => 'xx',
        'company' => '',
        'address' => 'xx N Riverside Ave',
        'city' => 'St Clair',
        'state' => 'MI',
        'zip' => 'xx079',
        'country' => 'US',
      ),
      'customerIP' => 'xx.49.12.69',
    ),   ),   'response' => '{"transactionResponse":{"responseCode":"3","authCode":"","avsResultCode":"P","cvvResultCode":"","cavvResultCode":"","transId":"0","refTransID":"","transHash":"","testRequest":"0","accountNumber":"XXXXxx52","accountType":"","errors":[{"errorCode":"6","errorText":"The credit card number is invalid."}],"transHashSha2":"581E58B78444F0AFCFAAE0F5C949EF2F773D190B63D2BBD53BA39E1F9AEF4DFB7C11F20B1E6163A5A146A8C92586BB049BE169FE40953E0A1F863EEB42BFFE55","SupplementalDataQualificationIndicator":0},"messages":{"resultCode":"Error","message":[{"code":"E00027","text":"The transaction was unsuccessful."}]}}', ) [] []

please advice Thanks

1
  • I have the same issue , did you find any solution Commented Nov 10, 2020 at 15:35

1 Answer 1

0

refTransId should be provided, you have NULL there. Try to dig on your side why it's passed as null to the gateway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.