1

Hosting - Amazon Mangeto 2.3.2 Apache

In developer mode, Magento creates symlinks in pub static directory, but when Magento try include static files on a page it responds with 403 error. I have tried change permissions to all files to 777, change owner but it doesn't work .htaccess files is the default. Now I generate static files with php bin/magento s:s:d but I should have a possibility to use symlinks. I will be appreciated for any advice.

2
  • 1) You're not running those commands that regenerate files as root are you? If you do ls . -dl in the public files directory, is the Magento user the owner still? 2) What does your config look like for the directory? Do you have FollowSymLinks like Options +Indexes +Includes +FollowSymLinks +MultiViews – Erik B Jun 13 '20 at 5:27
  • @ErikB 1) All files generated with root:root owner, but even when I change it to www-data:www-data and run chmod -R 777 ./ problem exists. 2) Magento .htaccess is not changed, it looks like apache is configured for using symlinks i.imgur.com/hfm1wM1.png, and in Plesk I unselect checkbox to allow use symlinks. i.imgur.com/SfC04is.png – Petro Chaikivskyi Jun 14 '20 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.