0

I'm Currently using Magento 2.3.4 and have a WAF setup which essentially functions as a reverse-proxy, which means that the integrations will not connect due to the site pointing to a different I.P. address.

As a workaround the WAF provider (Sucuri) has suggested setting up a subdomain on the server which points to the correct I.P address and have the integrations connect through that instead.

I have set up the subdomain now but I am not sure how to get Magento 2 to connect the Integrations to the site through the subdomain rather than the primary domain.

Does anyone know which setting I would need to change to allow this to happen?

  • You should also add which server nginx/apache and WAF you are using, my guess is just redirecting to same URI would solve the issue. – Vivek Kumar Jun 19 at 4:48
  • We actually use a mix of both. However, php is run by apache and .htaccess rules will be honoured. The WAF is bu SUCURI. – CJNotts Jul 6 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.