0

My magento 2 website performs well on pingdom and gtmetrix, but the performance on google pagespeed is very poor. How can I solve it?

enter image description here

enter image description here

enter image description here

5
  • Pingdom and Gmetrix are doing desktop only tests. Pagespeed screenshot is showing Mobile test result. Mobile vs Desktop results are different. Jun 5, 2020 at 18:21
  • YES. The PC score is 47
    – nextion
    Jun 5, 2020 at 18:23
  • Mobile score has a different requirement to Desktop score. I recommend running Right Click -> Inspect -> Lighthouse -> Generate Report to see where there issue is. Here is a quick rundown how to use it to improve load times: developers.google.com/web/updates/2018/05/lighthouse I did notice the scores definitely have changed - I optimized my score in october to 64%, but now its only 30%. So something has changed in their tool. Start with Lighthouse and keep working. Jun 5, 2020 at 18:27
  • thanks, i will check it
    – nextion
    Jun 5, 2020 at 18:28
  • Enable magento profiler and check if which profiler takes long time check if any loops are repetitive reduce no of http request. Remove all inline javascripts and css and create one js file or once css file so that when we merge css and js it will take only one http request Enable production mode in magento 2 using php bin/magento deploy:mode:set production. run compilation and check if any errors using this command php bin/magento setup:di:compile Check if all caches are enabled if not run this command php bin/magento cache:enable Jun 8, 2020 at 9:39

1 Answer 1

3
  • Enable magento profiler and check if which profiler takes long time
  • check if any loops are repetitive
  • reduce no of http request.
  • Remove all inline javascripts and css and create one js file or once css file so that when we merge css and js it will take only one http request
    • Enable production mode in magento 2 using php bin/magento deploy:mode:set production.
    • run compilation and check if any errors using this command php bin/magento setup:di:compile
    • Check if all caches are enabled if not run this command php bin/magento cache:enable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.