Am using Magento version 1.8.1. Created categories in admin and prepared the CSV file filling out all the categories for the products.

when importing am getting error "category does not exist in row .." when i checked the csv file the categories are all there. Checked for the case sensitivity too. I used find method in the browser and the categories are found.

Import error

Import error

My categories in admin

Admin categories

My CSV file.

CSV file

Please advice me to solve this issue. Thanks.

Saving the csv file to UTF-8 Solved the issue. But after that when i import, i get errors on other categories.
Some category rows in csv file are
Apparel/Girls Clothes 2T - 4T/Dresses - Daywear
Madame Alexander/Supplements For Dolls/Doll Clothes 16" And Up
I get category not exist where ever i have the (-),(") and numbers in category names in CSV.
Checked for the spaces and case-sensitivities and its all correct.
Please help me to solve this issue..

  • 1
    did you check your file encoding as being UTF-8(without BOM)? Aug 6, 2014 at 12:01
  • you may missed any one value in this row or white spacing. check it
    – Manikandan
    Aug 6, 2014 at 12:04
  • @JulienLachal Oh, i forgot that part. My csv was in ANSI and i changed it to UTF-8 and voila, the problem solved. Thanks for remaining.
    – Franc
    Aug 6, 2014 at 12:07
  • @Marius :: The problem is still not yet resolved. Please see the update section in my question. Should i still answer it ?
    – Franc
    Aug 6, 2014 at 12:49
  • Ah. Sorry. I didn't see the update. I think you should wait a bit more.
    – Marius
    Aug 6, 2014 at 12:52

1 Answer 1


Initially My CSV file was in ANSI encoding format. Saving the CSV file to UTF-8 encoding Solved the issue.
But after that when i import, i get errors on other categories. WHICH WAS DUE TO SPACING BETWEEN THE SLASHES SEPARATING THE CATEGORIES.
I Looked for the Case-sensitivity and fixed few and now all the products are imported, Even if my category name contains (-) (") and numbers.
Thank you.

  • 1
    Hate spaces lol. Glad you fixed it yourself, please accept your answer so as this question is marked as solved. Aug 7, 2014 at 7:13
  • @JulienLachal :: Yeah. Thanks to you for the initial heads up on UTF-8. I can only accept my answer tomorrow. I got alert like that when i tried to do.
    – Franc
    Aug 7, 2014 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.