0

I have been battling with a client's magento store, all other shipping methods are working correctly but FedeX shipping method is not working, both at the back-end and front-end. It keeps giving the error message: "This shipping method is currently unavailable. If you would like to ship using this shipping method, please contact us." I have tried different things (including rolling back the whole store to a day that everything was fine) in an attempt to resolve the issue but with no success.

I checked the var/log file and found the following:

[request] => Array ( [WebAuthenticationDetail] => Array ( [UserCredential] => Array ( [Key] => 720LsKGjPnK6nhZh [Password] => wchEHJ9GClXDcYdw13lWrHq6W )

            )

        [ClientDetail] => Array
            (
                [AccountNumber] => adetclement
                [MeterNumber] => 250017020
            )

        [Version] => Array
            (
                [ServiceId] => crs
                [Major] => 10
                [Intermediate] => 0
                [Minor] => 0
            )

        [RequestedShipment] => Array
            (
                [DropoffType] => BUSINESS_SERVICE_CENTER
                [ShipTimestamp] => 2020-06-02T12:58:01+00:00
                [PackagingType] => YOUR_PACKAGING
                [TotalInsuredValue] => Array
                    (
                        [Amount] => 95.99
                        [Currency] => USD
                    )...

I noticed that the [AccountNumber] => adetclement and [MeterNumber] => 250017020 are not the correct details of FedEx account, I'm not sure if that is normal to happen.

And at the end of the file there is error message saying authentication failed, as shown below: [result] => stdClass Object ( [HighestSeverity] => ERROR [Notifications] => stdClass Object ( [Severity] => ERROR [Source] => prof [Code] => 1000 [Message] => Authentication Failed )

        [Version] => stdClass Object
            (
                [ServiceId] => crs
                [Major] => 10
                [Intermediate] => 0
                [Minor] => 0

I'm still battling with this, someone that has dealt with this kind of issue before should please help. Thanks

0

You might want to check your fedex account details to make sure they're all correct, since authentication failed is in log file

| improve this answer | |
  • I checked fedex account credentials as you suggested, everything checked out but the issue still persists – AYC Jun 2 at 17:46
  • Hi clemxytech, I re-visited your suggestion after exhausting all available options by checking the log file again and realized that every time I attempt to place order different account number appear in the log file. So I checked the account number and found the error: I input the account number just as fedex sent it to my inbox with preceding xxxx (xxxx012), I changed that and input the full account number and now I'm happy. Thanks for your suggestion. – AYC Jun 3 at 9:44
  • For anyone having issue with fedex working with magento, I found out that enabling debug and checking var\/log file is very crucial to getting a solution, as the exact reason for issue is always in the log file. And as for authentication failure with error code 1000, always verify your credentials and gateway url as that's the only reason for such error – AYC Jun 3 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.