0

Magento Version: 2.3.5p

Hey guys, I am not sure if you have gotten a similar error during checkout:

Internal Error. Details are available in Magento log file. Report ID: webapi-5ed2c83e06062

Looking at the browser console, I am seeing the following:

POST magentowebsite.com/index.php/rest/default/V1/guest-carts/szvNnGiFGE2eeRTxVX7n5N32pnr7kyfX/estimate-shipping-methods 500

I also looked into the /var/log/exception.log and this is what I am seeing:

[2020-05-30 20:55:26] main.CRITICAL: Report ID: webapi-5ed2c83e06062; Message: cURL error 7:  (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) {"exception":"[object] (Exception(code: 0): Report ID: webapi-5ed2c83e06062; Message: cURL error 7:  (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) at /var/www/html/vendor/magento/framework/Webapi/ErrorProcessor.php:208, Magento\\Framework\\HTTP\\AsyncClient\\HttpException(code: 0): cURL error 7:  (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) at /var/www/html/vendor/magento/framework/HTTP/AsyncClient/GuzzleWrapDeferred.php:88, GuzzleHttp\\Exception\\ConnectException(code: 0): cURL error 7:  (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) at /var/www/html/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:200)"}

I've tried a few fixes, including changing the Gateway URL for USPS to use https instead of HTTP.

Has anyone faced a similar issue before? Thank you in advance.

  • Did you checked URL status under Network tab of your browser developer tool. Also make sure Curl installed on the server. – Pritam Info 24 May 31 at 7:38
  • @PritamInfo24 Hey I have checked the network tab and it looks like it does the 301 and then the rest is 200. Also curl 7.61.1 is installed on my server. Where else would you recommend me look? Would SELinux, .htaccess, or SSL have anything to do with this? Thank you so much. – J W Jun 6 at 19:54
1

This is the solution for anyone facing the same issue.

Since the newer versions of CentOS all come with SELinux enabled, we need to adjust the httpd can network connect boolean so that curl can be used.

/usr/sbin/setsebool httpd_can_network_connect 1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.