0

I have a site in magento 2.3.2. My code is getting fetched from var/view_processed instead of directly from app/code and app/design. See https://prnt.sc/slkvss The css and css also not getting applied properly. Refer this link of my site https://wazoodl2.wsisites.net What is the issue. I ran all the commands multiple time, still no affect.

2
  • disable the minify of js May 22, 2020 at 8:21
  • @YasirLatif Did. but still same problem
    – Nafsss
    May 22, 2020 at 8:56

2 Answers 2

0

It is possible that you may need to refresh the static content, as there might be missing content. Which commands did you run?

From your website link it is clear inspecting the Console, all your Javascript are giving errors, 'xyz is not a function'.

Firstly disable your path hints.

bin/magento setup:upgrade
bin/magento setup:static-content:deploy -f en_US <lc_extra> <lc_extra2>
bin/magento cache:flush

-f Switch forces refresh of static content.

Sometimes even in developer mode static content is not automatically refreshed. (Might be module specific)

2
  • i ran all these commands. Still no affect. and y the code is fetched from var/view_processed?
    – Nafsss
    May 22, 2020 at 9:11
  • I am running Magento 2.3.5, I just confirmed everything is in vendor/* for .phtml files (I assume you might be running production mode, atm using developer mode). Also, my JS / CSS files are pub/static/versionYYYYY/frontend/* I have checked your website right now, the styling looks much better than earlier today, I do not see the 100s of requirejs 'is not a function' errors in the console. Seems you managed to fix it? May 22, 2020 at 10:42
0

Simply delete the contents of var/view_preprocessed/*. This is a cache directory and safe to delete:

https://devdocs.magento.com/guides/v2.3/howdoi/php/php_clear-dirs.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.