0

Hello everyone I have a issue that I can not pin point at this time.

I am running magento at http://mytempsite.net/gotie and then have a wholesale store setup on the same installation at http://mytempsite.net/gotie/wholesale.

The issue is when I go to checkout on mytempsite.net/gotie when I click proceed to check out it goes to the next page but I am not able to move past the "Checkout as Guest, Register or Login Page" If i try loggin using an existing test account it loads the next step but under billing information there is absolutely nothing (Test Login: admin@admin.com pass: hayden927 )

But when I go to the wholesale site mytempsite.net/gotie/wholesale and add a product to cart I am able to go through all the steps just fine. You will need to login to see the catalog using the following information (Test Login: nick@nick.com pass: hayden927 )

What I have Tried
I have tried disabling all 3rd party plugins and modules.

List of 3rd Party Modules That Came with Theme?
Amasty Improved Navigation
Itoris Registration Fields (Wholesale Site)
Netzarbeiter Customer Activation (Wholesale Site)
Netzarbeiter Login Catalog (Wholesale Site)


List of 3rd Party Modules I installed
Phoenix Money Bookers
Webdziner Ajax Search
Webdziner All
Webdziner Bgsetting
Webdziner New Product

closed as too localized by Ben Lessani - Sonassi, Marius, Fabian Blechschmidt, davidalger, philwinkle Apr 23 '13 at 18:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Unfortunately, this site doesn't exist to answer such specific questions (that your developer should be carrying out). Extremely localised questions such as this are not permitted on SE. – Ben Lessani - Sonassi Apr 19 '13 at 17:12
  • Someone still might be able to help... – Nick Darley Apr 19 '13 at 17:15
  • 1
    I appreciate you are new (so welcome!). And your comment may well be true - but sadly its not the purpose of the site. It is here to serve as a valuable Q&A knowledge base that offers answers to questions that apply to all users of Magento. Any answer to this question would be wholly inappropriate to anyone else using this site - because the issue is so localised. Have a look at this meta.stackexchange.com/a/87415 – Ben Lessani - Sonassi Apr 19 '13 at 18:00
  • This question is posted on elance as a job elance.com/j/magento-checkout-page-not-working/40510872 And now the site mytempsite.net/gotie working fine with its default magento checkout. I think your developer has fixed the issue. If you have any doubts contact your developer who done this Job. If you Know the answer to this question share with us. Don't put such kind of questions and your client projects on StackOverflow and stackexchange Because Such kind of Extremely localised questions are not permitted on stackexchange and stackoverflow. – Magento User Apr 21 '13 at 13:58
0

I think there is an issue with your billing.phtml file. For some reason the content of the billing address container is empty.
It looks like this:

<div id="checkout-step-billing" class="step a-item" style="display:none;">
                    </div>

There should be some content inside the div. Actually a lot of content. Make sure there are no errors in app/design/frontend/{interface}/{theme}/checkout/onepage/billing.phtml. or if the file even exists. You can enable the logging and check the var/log folder for errors.

  • 1
    even if I answered, I agree with @sonassi, this is not a question suited for this website. I will not encourage and/or answers any questions like this anymore, your luck is that I had a similar issue before. :) – Marius Apr 19 '13 at 21:25
1

As you're a new user, I don't want you to feel to un-welcome. But I do fear this question will be closed.

Your "checkout as guest" issue is a JS error on the checkout

Timestamp: 19/04/2013 19:07:09
Error: TypeError: element is null
Source File: http://mytempsite.net/gotie/js/prototype/prototype.js
Line: 1931

Follow this to the letter, and you'll identify your fault.

Fundamentals for debugging a Magento store

  • thank you sonassi and while this may be localized I can see I am not the only magento user with this issue. But all the solutions people have posted don't work for me so I figured I would give it a shot and thank you for taking the time to look into it. I figured it was JS when I switched to the default theme and the same thing still happened. – Nick Darley Apr 19 '13 at 18:28
  • Just because other people share an issue with similar symptoms - certainly does not mean its the same issue. Magento is infinitely customisable and that means the bugs are infinitely variable. If a bug is in the core - then posting a question here will encourage an answer that will help others. But your bug is specific to your store (regardless of whether others have similar symptoms). There is a thousand reasons a checkout page would behave that way (ie. there is a lot of ways to break JS), but no 1 solution is going to be accurate, thus too localised. – Ben Lessani - Sonassi Apr 19 '13 at 18:41
  • I am also now seeing Uncaught ReferenceError: billing is not defined – Nick Darley Apr 19 '13 at 18:47
  • OK following you instructions i am having issue with this EGIN BY DISABLING LOCAL Just rename the directory via FTP, or use the following SSH command mv ./app/code/local{,.tmp} THEN DISABLE COMMUNITY mv ./app/code/community{,.tmp} when i do this my site wont load anything after the header on my custom theme – Nick Darley Apr 19 '13 at 19:34
  • @sonassi - classy to answer anyhow. Cheers mate. – philwinkle Apr 21 '13 at 23:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.