0

I tried upgrading a magento store from 2.3.2 to 2.3.5, but when i run

 php bin/magento setup:upgrade

I recieve a strange database error relating to a index on the sales_shipment_grid table:

SQLSTATE[HY000]: General error: 1283 Column 'shipping_name' cannot be part of FULLTEXT index, query was: ALTER TABLE `sales_shipment_grid` MODIFY COLUMN `entity_id` int(10) UNSIGNED NOT NULL   COMMENT "Entity ID", MODIFY COLUMN `increment_id` varchar(50) NULL  COMMENT "Increment ID", MODIFY COLUMN `store_id` smallint(5) UNSIGNED NULL   COMMENT "Store ID", MODIFY COLUMN `order_increment_id` varchar(32) NOT NULL  COMMENT "Order Increment ID", MODIFY COLUMN `order_id` int(10) UNSIGNED NOT NULL   COMMENT "Order ID", MODIFY COLUMN `order_created_at` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP COMMENT "Order Increment ID"

I checked the web for this error, and found some people saying that all the Encoding and Collation fields should be the same for this index. But those all seem to be the same in this table (Encoding: cp1252 West Europe and Collation: latin1_swedish_ci).

Anybody encounter this issue before, or know a possible solution?

MySQL version is 5.7.26

1 Answer 1

0

For people hitting the same error:

ALTER TABLE sales_shipment_grid CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;

Fixes the problems!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.