2

I tried to migrate producs from magento 1.9.3 to magento 2.3, everything is okay until I check the configurable product. Then I found associated product on the configurable product is null but the simple product is already migrated like this below screenshot:

enter image description here

enter image description here

So how I can migrated the links of configurable with associated product too. If someone already have same issue and solved it, please advise.

update :

here is my catalog_product_super_link table it the relation data has been migrated, but it not applied on the website product

enter image description here

  • did you get any solution I am facing the same issue after migration from magento 1.9. – Manish Goswami Oct 20 '20 at 7:37
  • any solution for this ? – SebastianT Nov 2 '20 at 8:09
  • @SebastianT yes I've fixed this, please check your attribute variant configurable product and check on each table which store the data. Look like the attribute value not migrated successfully, on my case the color attribute data not imported from catalog_product_entity_int table magento 1 so I try to copy manual from magento 1 table to magento 2 table only for color attribute and my problem solved. – mrfizh Nov 4 '20 at 6:21
  • @mrfizh Thanks for answer. I had problem only with color attribute. In my case (and i think in most cases) the problem was, because color attribute is not in default attribute set. And after migration it wasn't assigned to any attribute set. The solution was to assign color attribute to default attribute set before running the migration and everything went correct. – SebastianT Nov 5 '20 at 20:18
1

Finally, I've already solve this issue, it because there is one of the attribute which used on configurable not imported successfully, as in my website variant product from configurable is by size and color when I see the color attribute table, the color not migrated successfully and it show nothing on table catalog_product_entity_int for attribute color data, so I try to copy the table data for attribute color from table catalog_product_entity_int in magento 1 database to magento 2 table. and it works, all my configurable products now show the variant.

Maybe this is not best answer, since it can be caused by some problem when migrated database from magento 1 to magento 2 but, especially for my this case I hope it will help someone who get same issue with me.

1

My solution for this problem:
I had problem only with color attribute. In my case (and i think in most cases) the problem was, because color attribute is not in default attribute set. And after migration it wasn't assigned to any attribute set. The solution was to assign color attribute to default attribute set in Magento2 before running the migration and then everything went correct.

  • glad to know you've solved your issue, so the problem because color is not in default attribute set in magento 1 db, ah thank you it will be my note for this problem in next time. – mrfizh Nov 6 '20 at 8:08
  • Hi @mrfizh i had to assign color to default attribute set in Magento2 before migration :D – SebastianT Nov 6 '20 at 8:35
0

You need to check in the catalog_product_super_link table whether there is a link between the configurable products and the associated products

  • yes the link has been migrated, but it's not applied on the product on the website. please see my update – mrfizh May 31 '20 at 15:56
  • Please check whether the attributes of the simple products are set up or not. To get the attribute id, you should check in the catalog_product_super_attribute table, all the simple products with the attributes need to be there, in this table. – LitExtension Magento Migration Jun 2 '20 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.