0

I have setup fresh magento 2.3.2. When i access frontend, the content does not appear properly See https://prnt.sc/sfwlaf I had run all the commands also, still it does not gets affected. How to solve this? This is fresh magento installtion,no changes have been made.

3
  • Upload your image in another authentic website – Ahmed Chouihi May 13 '20 at 9:56
  • could you please specify installed php version ?? – Abdul Pathan May 13 '20 at 10:02
  • check console error – Mohit Patel May 13 '20 at 10:02
0

Once Magento is installed, if the site does not load, I suggest several steps to troubleshoot and resolve:

** before doing anything, you might want to verify whether the issue is server related or magento related. Just put a die php statement in your index.php file and verify you can see the die will tell you whether the web server is the origin of the problem

  1. the first thing to do is to setup your site to be a developer Magento instance that is safe and ready to be debugged:

    • Enable the developer mode as it will show the errors more clearly but also deal with the css and media in real time mode (rather than using compilation) run bin/magento deploy:mode:set developer
    • Reset the sites permissions (see https://devdocs.magento.com/guides/v2.3/config-guide/prod/prod_file-sys-perms.html)
    • finally, clear var/cache, generated content and flush redis cache if used (do the latter each time something is changed for your sanity)
  2. If your install is in developer mode and the above is out of the way:

  3. then run bin/magento setup:upgrade (and bin/magento cache:clean) these commands will help to ascertain where is the issue. --> If the cache command fails for instance, it is very useful to reset the Magento permissions , --> if setup:upgrade fails, it is often a new config changes, config syntax and so on

If the above is not resolving the problem, we are now trying to find an error that has not bubble up yet:

  • check log in var/log and var/report, then in your server
  • check console error in your browser
  • ensuring the database connection works is something I have come across recently --> if you have a backup beforehand as this is a last resort method, you may remove env.php and config.php and trigger the site as if you were installing it by the browser. This will perform the health check of your system and that is very useful to consolidate your understanding above
5
  • Hi, frontend loaded properly. but on accessing admin panel, i am getting too many redirect error see prnt.sc/sfxquf – Nafsss May 13 '20 at 10:46
  • more than likely cache issue it seems to me, or rewrite mod not enable but I guess you have this sorted.. – Herve Tribouilloy May 13 '20 at 10:47
  • what to do then? – Nafsss May 13 '20 at 10:48
  • vote for my answer first and then perform the steps from my answer might help – Herve Tribouilloy May 13 '20 at 10:49
  • sry i did not find your ans helpful – Nafsss May 13 '20 at 10:50
0

b1 . in your folder magento, run :

sudo a2enmod rewrite
sudo a2ensite magento2.conf

b2 change : sudo gedit /etc/apache2/apache2.conf

<Directory /var/www>
    Options Indexes FollowSymLinks MultiViews
    Require all granted
    AllowOverride All
    Order allow,deny
    allow from all
</Directory>

b3 : run sudo service apache2 restart

  • error admin page because you have some error when you install without run this :
  • before you install magento 2, you have to run :

    cd /var/www/html/<magento install directory> find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + chown -R :www-data . # Ubuntu chmod u+x bin/magento.

  • now, you install magento 2

  • after that, you run :

sudo chown -R www-data:www-data /var/www/html/magento2/ sudo chmod -R 755 /var/www/html/magento2/

1
  • This worked for me. frontend appears normal. but i am not able to access admin panel. it is giving me 404 not found error. Its a redirect issue, i am not able to go to any inner pages – Nafsss May 13 '20 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.