0

Installing user configuration... [ERROR] CredisException: Connection to Redis localhost:6379 failed after 2 failures.Last Error : (10061) No connection could be made because the target machine actively refused it.

0

First make sure you have Redis enabled in Xampp. Follow these instructions. A quicker way is to run redis-cli ping you should receive a PONG.

If successful then you may be missing the configurations needed for magento to communicate to the redis server.

It is recommended in the Magento 2 docs to run the magento CLI commands as it has further checks in place.

An example command: bin/magento setup:config:set --cache-backend=redis --cache-backend-redis-server=127.0.0.1 --cache-backend-redis-db=0

Typical Redis settings are: IP: 127.0.0.1 PORT: 6379

Remember if you are using redis for other caching or session storage, I would recommend using another Number for your redis DBs to separate them.

If you want to check that redis keys are being populated (after a page refresh or action) then run this sequence of commands:

  1. redis-cli (enters you into redis)
  2. SELECT 0 (Number is your database number chosen)
  3. KEYS * (Will output values in Redis DB)

redis-commands-magento

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.