1

After upgrade from Magento 2.2.4 to 2.3.4 the category data not saving. However the category saves correctly and shows the correct saved message. But data inside it not loading.

While troubleshooting I have found in table "catalog_category_entity" if I edit any category Id(entity_id), it shows default attribute_set_id = 0. But the default magento category attribute_set_id is 3(catalog_category).

So while saving category,In table "catalog_category_entity" the value changes for attribute_set_id=3 from zero for a category. And data not showing in admin.

If I revert and change back to attribute_set_id = 0, all category attributes data showing in admin.

Any idea about this type of issue post upgrade to 2.3.4 ?

0

In the table eav_entity_attribute, you should check whether all the category's attributes are put into the right attribute set.

0

Check eav_entity_attribute table. it must have a record for the entity type category for all need attribute.

for e.g (me) category name attribute has id : 41 categry entity type id = 3 attribute_set_id = 3 attribute_group_id = 1

then eav_entity_attribute should have a record with

SELECT * FROM eav_entity_attribute WHERE attribute_id = 41 and entity_type_id = 3.

if not then please add respective for missing attributes

INSERT INTO eav_entity_attribute (entity_attribute_id, entity_type_id, attribute_set_id, attribute_group_id, attribute_id, sort_order) VALUES (NULL, '3', '3', '4', '41', '0');

*** note: query will be based on your records, above given as just example

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.