3

Yesterday I messed something up on my Magento installation. A plugin destroyed the test environment, so I've decided to reïnstall the test environment.

I got the back-up database from our working live site, as well as the map structure.
Put everything in place in the local HtDocs folder and changed the database url's and the local.xms file to the appropriate parameters.

Everything seems to work, however when I go to the back-end and log in... it just refreshes and does nothing.

I have read a lot about restoring cookies and editing the varien file.
/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php

However, this does not work.
So far I've tried:

  • changing the web/cookies url's in the database;
  • clearing the var/cache folder;
  • clearing the browser cookies and cache;
  • edit the varien.php file.
  • It doesn't seem to work, the front end works fine.

    • Did you clean session in /var/sessions? Are you sure your /app/etc/local.xml points to the right palce for your admin? – Julien Lachal Aug 5 '14 at 7:32
    • It appears my Magento installation doesn't have a /var/sessions folder. I am sure the /app/etc/local.xml file points to the right place. – GrayleBV Aug 5 '14 at 7:39
    • it's /var/session my bad. Do you have any error in your Apache logs? or in Magento logs for that instance. – Julien Lachal Aug 5 '14 at 7:43
    • Doesn't matter if it's /var/session or /var/sessions I haven't got either =). There are no error logs from Magento or Apache. – GrayleBV Aug 5 '14 at 7:45
    • are you sure your local.xml points to the right place and that it points to the right database? – Julien Lachal Aug 5 '14 at 7:51
    2

    I would guess this is to do with the cookie domain you have set up, not being correct in your new development environment, OR, matching one that you're also using (if you have multiple Magento installations set up)

    Check the core_config_data table and the entry with a path of web/cookie/cookie_domain. Try clearing this, and then clear your browser cache and try logging in again.

    2

    It's working for me.. Please follow below instruction

    Goto System->Configuration->Web->Session Cookie Management

    change the option 'Use HTTP only' to 'No'
    enter image description here

    1

    I recently had the same problem and simple trick worked for me. Also this is for people who cannot access the dashboard on Google Chrome. If you can carry on by working on Mozilla Firefox then please do so because I guess this issue is not persistent on Mozilla firefox.

    So the solution for chrome is:

    Goto System->Configuration->Web. Expand the Unsecure and Secure tab. Change the Base URL to http://127.0.0.1/[Your folder name] if your using localhost or change it to your Site URL through which you are accessing the frontend. I had to login twice to get the Dashboard since when I entered the details for the first time, it just refreshes and comes back to the same page as you mentioned it as looping. Please try and let me know whether it worked for you too.

    0

    I just ran into the same problem, but in a different scenario. I had a working, live Magento install that one morning I suddenly wouldn't let me log in to the admin. It did what you described when I tried to log in - just reloaded. It turned out to be a disc quota issue.

    Solution

    We upped the available space and everything was right again. Check with your hosting to make sure you've got enough disc space, bandwith, etc and that nothing is over the limit.

    0

    Please check in core_config_data if the value of web/cookie/force_secure_cookie is set to 0.

    When you restore a backup from a secure domain (https) to an unsecure (http) domain, this setting might be set to 1, which won't work on a unsecure domain.

    -1

    Have you tried below ? Every ever new installation I faced same problem and it worked like charm

    I think there is the problem with session cookie with the chrome browser. So just go through this directory /app/code/core/Mage/Core/Model/Session/Abstract/Varien.php file and comment out the line from 85 to 92 in magento (1.7.2 for my case). Like this

      // session cookie params
       /* $cookieParams = array(
            'lifetime' => $cookie->getLifetime(),
            'path'     => $cookie->getPath(),
            'domain'   => $cookie->getConfigDomain(),
            'secure'   => $cookie->isSecure(),
            'httponly' => $cookie->getHttponly()
        );
      */
    

    after that try to make login from your backend. Hopefully you can make login with chrome. This will definitely help you. If you are still facing the problem then just reply me.

    • 1
      I see this solution a lot on the web. This is wrong. Even if apparently fixed the problem, it doesn't. It just hides the dirt under the rug. You should not edit core code. And that code is there for a reason. You should not remove it. For sure there is an other solution. – Marius Jan 5 '15 at 11:46

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.