1

I have uploaded the extension on the marketplace but it's failed in varnish test.

Error:- Your requirements could not be resolved to an installable set of packages.  Problem 1    - Conclusion: don't install composer

Status PASS in the report for the following configurations:

Environment: PHP 7.1.33 Magento 2.3 EE
Environment: PHP 7.1.33 Magento 2.3 CE
Environment: PHP 7.2.30 Magento 2.3 EE
Environment: PHP 7.2.30 Magento 2.3 CE
Environment: PHP 7.3.17 Magento 2.3 EE
Environment: PHP 7.3.17 Magento 2.3 CE

Status FAIL in the report for the following configurations:

Environment: PHP 7.1.33 Magento 2.2 EE
Environment: PHP 7.2.30 Magento 2.2 EE
Environment: PHP 7.0.32 Magento 2.2 EE

Here is the report from marketplace,

{
   "tool":"varnish",
   "status":"FAIL",
   "reports":[
      {
         "php_version":"7.1.33",
         "magento_platform":"M2",
         "magento_edition":"EE",
         "magento_version":"2.2",
         "tool":"varnish",
         "myvendor":"myvendor",
         "extension":"module-giftcard",
         "version":"2.0.2",
         "status":"FAIL",
         "date":"2020-05-07 13:45:00",
         "details":[
            {
               "command":"composer require myvendor\/module-giftcard:2.0.2 2>&1",
               "output":".\/composer.json has been updated
               Loading composer repositories with package information
               Updating dependencies (including require-dev)
               Your requirements could not be resolved to an installable set of packages.

                 Problem 1
                   - Conclusion: don't install composer\/composer 1.10.6
                   - Conclusion: don't install composer\/composer 1.10.5
                   - Conclusion: don't install composer\/composer 1.10.4
                   - Conclusion: don't install composer\/composer 1.10.3
                   - Conclusion: don't install composer\/composer 1.10.2
                   - Conclusion: don't install composer\/composer 1.10.1
                   - Conclusion: don't install composer\/composer 1.10.0
                   - Conclusion: don't install composer\/composer 1.10.0-RC
                   - Conclusion: don't install composer\/composer 1.9.3
                   - Conclusion: don't install composer\/composer 1.9.2
                   - Conclusion: don't install composer\/composer 1.9.1
                   - magento\/framework 102.0.5 requires composer\/composer ^1.9 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - Conclusion: don't install composer\/composer 1.9.0
                   - Conclusion: don't install composer\/composer 1.8.6
                   - Conclusion: don't install composer\/composer 1.8.5
                   - Conclusion: don't install composer\/composer 1.8.4
                   - Conclusion: don't install composer\/composer 1.8.3
                   - Conclusion: don't install composer\/composer 1.8.2
                   - Conclusion: don't install composer\/composer 1.8.1
                   - Conclusion: don't install composer\/composer 1.8.0
                   - Conclusion: don't install composer\/composer 1.7.3
                   - Conclusion: don't install composer\/composer 1.7.2
                   - Conclusion: don't install composer\/composer 1.7.1
                   - Conclusion: don't install composer\/composer 1.7.0
                   - Conclusion: don't install composer\/composer 1.7.0-RC
                   - Conclusion: don't install composer\/composer 1.6.5
                   - Conclusion: don't install composer\/composer 1.6.4
                   - Conclusion: don't install composer\/composer 1.6.3
                   - Conclusion: don't install composer\/composer 1.6.2
                   - Conclusion: don't install composer\/composer 1.6.1
                   - Conclusion: don't install composer\/composer 1.6.0
                   - Installation request for myvendor\/module-giftcard 2.0.2 -> satisfiable by myvendor\/module-giftcard[2.0.2].
                   - Installation request for magento\/product-enterprise-edition 2.2.11 -> satisfiable by magento\/product-enterprise-edition[2.2.11].
                   - myvendor\/module-giftcard 2.0.2 requires magento\/module-catalog ^103.0 -> satisfiable by magento\/module-catalog[103.0.4-p1, 103.0.5, 103.0.4-p2, 103.0.0, 103.0.1, 103.0.2, 103.0.3, 103.0.2-p2, 103.0.4, 103.0.3-p1].
                   - magento\/module-catalog 103.0.4-p1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.5 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.4-p2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.0 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.3 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.2-p2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.4 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.3-p1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/framework 102.0.3-p1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.2-p2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.3 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.0 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4-p2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4-p1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - Conclusion: don't install composer\/composer 1.6.0-RC


                   Installation failed, reverting .\/composer.json to its original content.
               "
            }
         ]
      },
      {
         "php_version":"7.2.30",
         "magento_platform":"M2",
         "magento_edition":"EE",
         "magento_version":"2.2",
         "tool":"varnish",
         "myvendor":"myvendor",
         "extension":"module-giftcard",
         "version":"2.0.2",
         "status":"FAIL",
         "date":"2020-05-07 13:45:23",
         "details":[
            {
               "command":"composer require myvendor\/module-giftcard:2.0.2 2>&1",
               "output":".\/composer.json has been updated
               Loading composer repositories with package information
               Updating dependencies (including require-dev)
               Your requirements could not be resolved to an installable set of packages.

                 Problem 1
                   - Conclusion: don't install composer\/composer 1.10.6
                   - Conclusion: don't install composer\/composer 1.10.5
                   - Conclusion: don't install composer\/composer 1.10.4
                   - Conclusion: don't install composer\/composer 1.10.3
                   - Conclusion: don't install composer\/composer 1.10.2
                   - Conclusion: don't install composer\/composer 1.10.1
                   - Conclusion: don't install composer\/composer 1.10.0
                   - Conclusion: don't install composer\/composer 1.10.0-RC
                   - Conclusion: don't install composer\/composer 1.9.3
                   - Conclusion: don't install composer\/composer 1.9.2
                   - Conclusion: don't install composer\/composer 1.9.1
                   - magento\/framework 102.0.5 requires composer\/composer ^1.9 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - Conclusion: don't install composer\/composer 1.9.0
                   - Conclusion: don't install composer\/composer 1.8.6
                   - Conclusion: don't install composer\/composer 1.8.5
                   - Conclusion: don't install composer\/composer 1.8.4
                   - Conclusion: don't install composer\/composer 1.8.3
                   - Conclusion: don't install composer\/composer 1.8.2
                   - Conclusion: don't install composer\/composer 1.8.1
                   - Conclusion: don't install composer\/composer 1.8.0
                   - Conclusion: don't install composer\/composer 1.7.3
                   - Conclusion: don't install composer\/composer 1.7.2
                   - Conclusion: don't install composer\/composer 1.7.1
                   - Conclusion: don't install composer\/composer 1.7.0
                   - Conclusion: don't install composer\/composer 1.7.0-RC
                   - Conclusion: don't install composer\/composer 1.6.5
                   - Conclusion: don't install composer\/composer 1.6.4
                   - Conclusion: don't install composer\/composer 1.6.3
                   - Conclusion: don't install composer\/composer 1.6.2
                   - Conclusion: don't install composer\/composer 1.6.1
                   - Conclusion: don't install composer\/composer 1.6.0
                   - Installation request for myvendor\/module-giftcard 2.0.2 -> satisfiable by myvendor\/module-giftcard[2.0.2].
                   - Installation request for magento\/product-enterprise-edition 2.2.11 -> satisfiable by magento\/product-enterprise-edition[2.2.11].
                   - myvendor\/module-giftcard 2.0.2 requires magento\/module-catalog ^103.0 -> satisfiable by magento\/module-catalog[103.0.4-p1, 103.0.5, 103.0.4-p2, 103.0.0, 103.0.1, 103.0.2, 103.0.3, 103.0.2-p2, 103.0.4, 103.0.3-p1].
                   - magento\/module-catalog 103.0.4-p1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.5 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.4-p2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.0 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.3 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.2-p2 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.4 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/module-catalog 103.0.3-p1 requires magento\/framework 102.0.* -> satisfiable by magento\/framework[102.0.4-p1, 102.0.5, 102.0.4-p2, 102.0.0, 102.0.1, 102.0.2, 102.0.3, 102.0.2-p2, 102.0.4, 102.0.3-p1].
                   - magento\/framework 102.0.3-p1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.2-p2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.3 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.0 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4-p2 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - magento\/framework 102.0.4-p1 requires composer\/composer ^1.6 -> satisfiable by composer\/composer[1.10.0, 1.10.0-RC, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3].
                   - Conclusion: don't install composer\/composer 1.6.0-RC


                   Installation failed, reverting .\/composer.json to its original content.
               "
            }
         ]
      },
      {
         "php_version":"7.0.32",
         "magento_platform":"M2",
         "magento_edition":"EE",
         "magento_version":"2.2",
         "tool":"varnish",
         "myvendor":"myvendor",
         "extension":"module-giftcard",
         "version":"2.0.2",
         "status":"FAIL",
         "date":"2020-05-07 13:45:56",
         "details":[
            {
               "command":"composer require myvendor\/module-giftcard:2.0.2 2>&1",
               "output":".\/composer.json has been updated
               Loading composer repositories with package information
               Updating dependencies (including require-dev)
               Your requirements could not be resolved to an installable set of packages.

                 Problem 1
                   - magento\/module-catalog 103.0.3-p1 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.4 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.3 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.4-p2 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.5 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - magento\/module-catalog 103.0.4-p1 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.0.33) does not satisfy that requirement.
                   - myvendor\/module-giftcard 2.0.2 requires magento\/module-catalog ^103.0 -> satisfiable by magento\/module-catalog[103.0.4-p1, 103.0.5, 103.0.4-p2, 103.0.0, 103.0.1, 103.0.2, 103.0.3, 103.0.2-p2, 103.0.4, 103.0.3-p1].
                   - Installation request for myvendor\/module-giftcard 2.0.2 -> satisfiable by myvendor\/module-giftcard[2.0.2].


                   Installation failed, reverting .\/composer.json to its original content.
               "
            }
         ]
      },

I think the error is in require section of composer.json file but I'm not sure. I don't understand what could be causing this error.

composer.json

{
    "name": "myvendor/module-giftcard",
    "description": "Magento 2 Gift Card",
    "type": "magento2-module",
    "version": "2.0.2",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/module-catalog": "^103.0",
        "magento/framework": "^100.1||^101.0||^102.0"
    },
    "autoload": {
        "files": [ "registration.php" ],
        "psr-4": {
            "Myvendor\\GiftCard\\": ""
        }
    }
}

EDIT

I've tried changing the "require" section, but marketplace is sending the same report as mentioned above.

"require": {
        "php": "~7.0.13||~7.1.0||~7.2.0||~7.3.0",
        "magento/module-catalog": "103.0.*",
        "magento/framework": "100.1.*||101.0.*||102.0.*"
    },

If anyone has any ideas, please let me know.

  • The key errors are at the end: "your PHP version (7.0.33) does not satisfy that requirement". You need at least 7.1.3 – Danila Vershinin May 8 at 18:34
  • Thanks for your comment but what do you mean I need the php version 7.0? do I need to add the php version in composer.json? Also, this is submitted in the marketplace. – Mohit Rane May 11 at 4:18
0

I changed the require section of the composer.json file and it passed in marketplace varnish test,

"php": "~7.0.13||~7.1.0||~7.2.0||~7.3.0"

composer.json

{
    "name": "myvendor/module-giftcard",
    "description": "Magento 2 Gift Card",
    "type": "magento2-module",
    "version": "2.0.0",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "php": "~7.0.13||~7.1.0||~7.2.0||~7.3.0"
    },
    "autoload": {
        "files": [ "registration.php" ],
        "psr-4": {
            "Myvendor\\GiftCard\\": ""
        }
    }
}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.