I am trying to edit companies using the "Edit" link at the right of the grid of companies.

The link the link is trying to get to is as follows


The id number is valid when I look in the company DB table. I have tried this for any of the companies and I get the same result.

I am getting an exception thrown

The requested company is not found

I have started to work my way through the code in the /vendor/magento/module-customer module and I am about to start code tracing to see what is going on.

Has anyone else come across a similar situation where the company is not found when trying to edit? I am asking to try to save myself hours of hair pulling

1 Answer 1


@richard-luckhurst I had the same problem, but I could edit the company after to follow this step:


Activate company accounts
Set the Actions control to Set Active.

When prompted to confirm, click OK.
  • Hi @Marcelo did you get any solution for this issue? I am getting the same. Commented Sep 15, 2021 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.